Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread SAMA5 ETB trace.

    Post
    Hello, I moved the inquiry to a new thread as this question is not related to the other. Both J-Links support ETB trace on the SAMA5 target device. Do you get any error message? Which version of Ozone are you using? Do you get any error messages? Best…
  • SEGGER - Schoenen -

    Replied to the thread How to trim leading zeros in spinbox?.

    Post
    Hi, Try the code below. First get the EDIT handle from the SPINBOX and then modify the EDIT widget. Although it is not documented, you can pass the flag GUI_EDIT_SUPRESS_LEADING_ZEROES to the function EDIT_SetDecMode(). I will update the manual. C…
  • Ross Lee -

    Posted the thread How to trim leading zeros in spinbox?.

    Thread
    Is there any way to remove the leading zero in spinbox? For example, if I set the Min and Max of a spinbox as 10 and 100, then when I input the value '24' , the spinbox displays '024'. How can I remove the leading zero? Thank you.
  • 40490FDB -

    Replied to the thread SAMA5 ETB trace.

    Post
    I've tried the ATSAMA5D2 trace example from the tested devices link shown above, without success. I have a J-Link Base as well as a J-Link Ultra+. The documentation specifies J-Link Pro so perhaps someone can confirm that neither of my units will…
  • rise.cai -

    Replied to the thread How can I code for SystemView?.

    Post
    Ok~ Thanks for these answer. :) I have the other question: I coding base on FreeRTOS. My board is ZYNQ7020 which same nice in my mind. :D How can I dynamic link to systemview.so? ?( Best regards~ Rose Rise :)
  • rise.cai -

    Replied to the thread SystemView's bugs.

    Post
    Quote from SEGGER - Nino: “Hello, Thank you for your inquiry. 1: Will be fixed in a future SystemView source release. 2: Is not reproducible with the currently available SystemView sources: https://www.segger.com/downloads/jlink/systemview_target_src
  • SEGGER - Nino -

    Replied to the thread Keil Cortex-M7 ETM Trace support.

    Post
    Hello, Quote from DawidS: “I know Ozone - the last version I used didn't had the ability to search in ETM Trace log which made Ozone almost useless for us ” Could you elaborate how you can do this in Keil? I just tested the latest uVision version…
  • SEGGER - Nino -

    Replied to the thread SystemView's bugs.

    Post
    Hello, Thank you for your inquiry. 1: Will be fixed in a future SystemView source release. 2: Is not reproducible with the currently available SystemView sources: segger.com/downloads/jlink/systemview_target_src Which version are you using? Quote from…
  • SEGGER - Nino -

    Replied to the thread Ozone on debian buster segfault.

    Post
    Hello, Attached you can find an example SWO project that contains an Ozone project which will output the SWO stream in Ozone terminal. Could you give that a try? I tested it with our STM32F103 Nucleo Board that we have in house and everything is working…
  • CheMax -

    Replied to the thread Data Breakpoint expressions.

    Post
    Good day, Thanks, I did not immediately see your answer, I apologize. the following construction works: (uint32_t *) 0x20008948> 0x3c, where 0x20008948 - address of interesting variable. Best regards, Maxim
  • DawidS -

    Replied to the thread Keil Cortex-M7 ETM Trace support.

    Post
    Thanks you for your answer. For the best trace experience including Cortex-M7 tracing we recommend using our stand alone debug software Ozone: - I know Ozone - the last version I used didn't had the ability to search in ETM Trace log which made Ozone…
  • mringwal -

    Replied to the thread RTT with dual-core STM32WB55 stops.

    Post
    Hi Nino. Thanks for the reply - I'm sorry I didn't have notifications configured and didn't see your reply in time (but fixed that just now!) I have a straight-forward/naive setup: start ozone, use project wizard to pick the stm32wb55xx (only two…
  • SEGGER - Nino -

    Replied to the thread How can I code for SystemView?.

    Post
    Hello, Thank you for your inquiry. Happy to see your interest in SystemView. Currently we do not offer a public repository for collaboration and there are no plans to add such an interface. So the correct approach for now would be to either post us your…
  • SEGGER - Nino -

    Replied to the thread Redefinition of FLASH in SEGGER_Flash.icf.

    Post
    Hi JLuc, Thanks for verification. This explains why the build is failing with the new version as the new Linker script is referenced now where the regions are renamed to be more consistent. By adjusting the memorymap file or memory segments settings in…
  • jobrud -

    Posted the thread xSemaphoreTake() displayed as xQueueGenericReceive().

    Thread
    Hi All, I started to use SystemView with FreeRTOS and I noticed that it shows calls to xSemaphoreTake() will be displayed as xQueueGenericReceive(). Is that correct or is there something going wrong with my integration ? BR,
  • JLuc -

    Replied to the thread Redefinition of FLASH in SEGGER_Flash.icf.

    Post
    Hi, on my side the path is $(StudioDir)/samples/SEGGER_Flash.icf Regards Jluc
  • billium -

    Replied to the thread Ozone on debian buster segfault.

    Post
    They are not active at the same time and the SWO box is ticked. I am using a STM32F103C8 (blue pill) With PB3 wired to SWO and PB4 wired to NRST of the JLink plug. I have not done enough research on this last problem to waste any of your time on this, I…
  • bobrecny -

    Replied to the thread [SOLVED] Nordic License on MacOS Not Working.

    Post
    If you haven't already solved this, be sure you open SES, hit "Continue" on the license notice, then open a Nordic SDK solution from the file menu. The default "Hello" project is what's tripping up the license detection. Once you have a Nordic project…
  • SEGGER - Leon -

    Replied to the thread [SOLVED] RTT Client cannot connect to port 19021 anymore.

    Post
    Hello, We found the issue that caused RTTClient to fail when connecting to a running J-Link debug session. We have fixed this internally already. A release version of the J-Link software package that contains this fix is planned for Friday this week…
  • SEGGER - Nino -

    Replied to the thread Ozone on debian buster segfault.

    Post
    Hello, Great to hear that you are up and running again. Quote from billium: “If I can find out how I'll mark as solved. ” Don't worry I will take care of it. Quote from billium: “One point though, if I use JLinkSWOViewer I can see my…