Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • broca -

    Replied to the thread How to set VAR_BREAK_AT_THIS_SYMBOL in the jdebug.

    Post
    Hi Nino Thanks for picking this up. I was using v3.10a. The same behavior persists with v3.10c. If I had a working example of how to set this variable, I could figure it out. Kind regards Brian
  • SEGGER - Nino -

    Replied to the thread Using Embedded studio with a dual core STM32H745?.

    Post
    Hello, Currently the SEGGER Linker does not offer "convenience" features for multi-core debugging so you need to take care of placement manually. But if you can point us to a linker that provides such features we will gladly take a look and see if they…
  • SEGGER - Nino -

    Replied to the thread Processor frezzes after Enabled the Interrupt source.

    Post
    Hello, We tested the sample solution with a NUCLEO-F103RB and everything was working as expected. Do you have an eval board to test against? To make sure this is no setup issue as you are using a slightly different target device could you set the…
  • SEGGER - Nino -

    Replied to the thread How to set VAR_BREAK_AT_THIS_SYMBOL in the jdebug.

    Post
    Hello, Thank you for your inquiry. Which Ozone version are you currently using? In Ozone V3.10c there was a fix related to the break symbol. Could you give V3.10c a try and see if the behaviour improves? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] S32K144 d-flash programming failure.

    Post
    Hello Victor, Thank you for your feedback. Unfortunately there is not much improving space here for the error message as a verify can fail because of numerous reasons and during write no error was reported from the target devices Flash controller. We…
  • WZJ_SCUT -

    Posted the thread NO timestamp in SystemView.

    Thread
    <p>I am using SEGGER SystemView V2.52C to check the task in Freertos 10.1, MT7682 chip<span class="redactor-invisible-space">.</span></p><p><span class="redactor-invisible-space">I can read the Event, and Detail, but i cannot get Timestamp.(all the time…
  • victorp -

    Replied to the thread [SOLVED] S32K144 d-flash programming failure.

    Post
    Fabian, Sorry for the late reply. I suppose it can be closed (is there a way for me to close it?). The only thing I wish is that the J-Link error message to be more clear. Best, Victor
  • jona -

    Replied to the thread Hardware fault when in loop for longer time.

    Post
    Sounds like something is eating your stack, exceeding your heap , writing past the extent of an array or memory object? perhaps outside of emWin? Maybe?
  • awneil -

    Replied to the thread RTT Output Delayed by Deep Sleep?.

    Post
    certainly, Nordic's use of RTT with Sleep ensures that the RTT is "finished" before going to sleep ...
  • mookiedog -

    Replied to the thread RTT Output Delayed by Deep Sleep?.

    Post
    In case it wasn't obvious, here is sample output from two iterations. Source Code (28 lines)Lines 1 through 16 should get printed before the system goes to sleep for 4 seconds. Instead, only lines 1 through 11 get printed. Four seconds later, lines 12…
  • mookiedog -

    Posted the thread RTT Output Delayed by Deep Sleep?.

    Thread
    I am working with an Ambiq Apollo3 Cortex M4 processor on a SparkFun Artemis module using Segger Embedded Studio. I have a FreeRTOS program that performs a task every 4 seconds. The task takes roughly 100 mSec to run. When FreeRTOS has nothing to do,…
  • Sorry for the confusion. Our application is very power sensitive and the EFM32's debug interface uses a significant amount of power when enabled. This interface is enabled when hitting the "resume / go" button. I am looking for a method to "go" but…
  • bio_med -

    Replied to the thread Reading from SD card.

    Post
    Florian, I converted images to bitmap using bitmap converter. Is there a requirement for the file size/IS there a certain way to do it? I am using M565 so I open files through bitmap converter and convert it to 16 bit color 565 and save as *.bmp. I…
  • vikramtathe -

    Replied to the thread GIF display issue on LCD.

    Post
    Hello, On which target have you executed the program? I have shared emwin_support.txt file to verify the memory related configurations. Could you please verify memory related configurations and let me know what should be the correct configurations…
  • JanBurg -

    Replied to the thread Hardware fault when in loop for longer time.

    Post
    Thank you for your quick answer, Florian. My loop is not empty, a lot of calculations are done there which must not be delayed. And wouldn't GUI_Exec do the same as GUI_Delay? Can there be a hardware fault at all when not refreshing emWin? Regards Jan
  • SEGGER - Florian -

    Replied to the thread GIF display issue on LCD.

    Post
    Hi, I could run your example both in the simulation and on a target. So there is nothing wrong with your code. Do you have enough memory? emWin needs about 16KB of RAM for decompression of the GIF image. Best regards, Florian
  • thomask77 -

    Replied to the thread STM32H743 DBGMCU register reads as zero when using ETF-Trace.

    Post
    Do you have any update on this topic? Or do you have an example work-around script? It's not entirely clear how I could write one myself..
  • Akatosh -

    Replied to the thread Processor frezzes after Enabled the Interrupt source.

    Post
    Thank you for replay I moved the program by the import. I didn't follow the troubleshooting yet. I checked now the sample solution and it compiled but after I run debug the program instantly goes to "HardFault_Handler". And I think that is only just…
  • SEGGER - Florian -

    Replied to the thread Reading from SD card.

    Post
    Hi, I've tried to display your image with the sample, but nothing showed up on the screen. It worked fine with another BMP image though, so I guess something's wrong with your image file? You could convert it to another file type and still display it…
  • SEGGER - Florian -

    Replied to the thread Hardware fault when in loop for longer time.

    Post
    Hi, a loop like this keeps emWin alive: C Source Code (3 lines)I hope this solved your problem. Best regards, Florian