Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Erik -

    Replied to the thread IMXRT1020 will not program on secondary pinmux.

    Post
    Hello, We were able to reproduce not the same issue but a similar one. This one will be fixed in the next official version (V6.62b), scheduled to be available later today. Could you please give this version a quick try and provide feedback? BTW: I…
  • I tried those steps. See attached screenshots. Using JLink.exe, I can connect through the tunnel. Using SES 4.42 I can not connect through the tunnel. I tried both IP tunnel:SN and IP SN. forum.segger.com/index.php/Att…5ebd35917c0f70c7c48a37943
  • Matt S -

    Posted the thread Swipelist transparency.

    Thread
    Can the SWIPELIST widget support a transparent background? I have tried: (1) SWIPELIST_SetBkColor(hItem, SWIPELIST_CI_BK_ITEM_UNSEL, GUI_MAKE_COLOR(GUI_TRANSPARENT)); (2) WM_SetHasTrans(hItem); (3) a custom owner draw function emWin 5.38
  • SEGGER - Nino -

    Replied to the thread Import previously exported data graph in Ozone.

    Post
    Hello, The snapshot should be able to restore any amount of data samples. Could you give it a try? Is something not working when using the snapshot approach? Best regards, Nino
  • westloser86 -

    Replied to the thread embOS with SiLabs BLE library.

    Post
    Hello Til I'm not 100% sure, but my guess goes to the same direction that all used interrupts are initialized inside the BLE library from SiLabs. I will contact SiLabs directly in order to get some information what interrupts they are using and if any…
  • SEGGER - Til -

    Replied to the thread embOS with SiLabs BLE library.

    Post
    I guess the interrupt is initialized in the BLE library and you don't have the source code, correct? Anyway you can change the interrupt priority at any time later before your application starts. You just need to know which interrupt is used (I think…
  • westloser86 -

    Replied to the thread embOS with SiLabs BLE library.

    Post
    Just to be sure about that, I need to change the interrupt priority for the BLE library from SiLabs?
  • SEGGER - Til -

    Replied to the thread embOS with SiLabs BLE library.

    Post
    Quote: “As far as I understand, this means that I cannot call the OS_EVENT_SetMask function because my program is in an ISR with higher priority. I have no clue how I can resolve this issue. ” That's correct. embOS API must be called only from embOS…
  • Hello, Thank you for your inquiry. Such an issue is not known to us. A how to is explained here: wiki.segger.com/Connect_to_rem…_via_J-Link_Tunnel_Server Are you following these exact steps? What Embedded Studio version are you using? What is the S/N…
  • jetlee -

    Posted the thread Error starting process.

    Thread
    windows 10 SEGGER Embedded Studio for ARM Release 4.42a Build 2020021108.41362 Windows x64 SES reports "Error starting process d:\Program Files (x86)\GNU Tools ARM Embedded\5.4 2016q3\bin/arm-none-eabi-gcc" when compiling, it seems SES couldn't run…
  • westloser86 -

    Posted the thread embOS with SiLabs BLE library.

    Thread
    I'm working on a small private project where I want to use BLE to transfer data between my embedded system and a smartphone app. Below are some basic information before I start explaining my problem. 1. Which embOS do you use? embOS_CortexM_GCC V506…
  • jetlee -

    Now follows Administrator.

    Follow
  • mohammadsafarisouri -

    Posted the thread ili9341 in 8bit emwin.

    Thread
    hi I want to port emwin for ili9341 with stm32f407ve microcontroller in 8 bits mode. my ili9341 driver function work perfectly without emwin. when I add emwin to my project it not work.
  • Blunk -

    Posted the thread What makes something J-Link compatible?.

    Thread
    Hi, I recently sent an email into Segger support and Axel was kind enough to help answer some questions. Basically I was interested in using the J-Link EDU and Segger SDK to debug a Cyclone V SOC board(DE-10 nano by Terrasic) in baremetal mode.…
  • km12 -

    Replied to the thread 2D Graphic Library and v 5.44.

    Post
    Fixed now, thank you!
  • SEGGER - Florian -

    Replied to the thread emWin publics reference list.

    Post
    Hi, see the "Index" chapter in the user manual. You can download the manual here. Best regards, Florian
  • netoz -

    Now follows Sabu.

    Follow
  • SEGGER - Nino -

    Replied to the thread System-view patch file doesn't support Cortex-M3 based MCUs.

    Post
    Hello, Thank you for your inquiry. The provided files are just samples for some popular platforms. If you need a CM3 variant you can use the CM4F sample and modify it to fit CM3. What is needed to instrument the code is explained in the SystemView…
  • SEGGER - Nino -

    Replied to the thread Log - ERROR: Could not find SystemView Buffer.

    Post
    Hello, Thank you for your inquiry. You can set the buffer location manually. How is explained in the SystemView manual. Search for "SystemView cannot find the RTT Control Block, how can I configure it?", there is described how you can do it or on our…
  • SEGGER - Nino -

    Replied to the thread Total CPU Load is more than 100%.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide a recording of such session? You can save a recording with File->Save Data. Best regards, Nino