Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • wzf -

    Now follows msantoli.

    Follow
  • SEGGER - Nino -

    Replied to the thread [SOLVED] How to use precompiled libraries.

    Post
    Hello Roger, Thank you for your inquiry. Great to hear that you are up and running again. We will mark this thread as solved now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone Data Sampling Number Formatting Inconsistent.

    Post
    Hello, Thank you for your inquiry. In the Average tab this was reproducible, but not in #Changes. Does this happen only for some data types or always? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone Data Sampling Change Counter becomes negative.

    Post
    Hi, Thank you for your inquiry. Good catch. Should be fixed with the next version. Sorry for any inconveniences caused. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Cannot quit Ozone after J-Link lost connection to target.

    Post
    Hello, Does your target application have any watchdogs, low power modes or similar running that might interfere with the debug interface? You seem to record quite a chunk of data samples, does the freeze happen around the same samples number each time…
  • SEGGER - Nino -

    Replied to the thread Import previously exported data graph in Ozone.

    Post
    Hi, Snapshot Files can be loaded without the other PC having a J-Link or the hardware. All you need is the .jdebug file, the elf file (if snapshot features are used where symbol information is needed) and the snapshot file obviously. So you open the…
  • bio_med -

    Posted the thread Problem displaying 320*240 image from SD card.

    Thread
    Hi, I am working on displaying images from external memory. I am having problems displaying the complete picture. I can display image up until 170*240, after which when I try to expand x value I see white background and nothing else on the LCD. Please…
  • grobot -

    Replied to the thread [SOLVED] How to use precompiled libraries.

    Post
    Hello Nico, Thank you for your answer, it helped me further. As you supposed I was using the wrong library. I've changed it to the bsec floating point library ...Cortex_M4F/libalgobsec.a and now it compiles without errors. Regards, Roger
  • dmarples -

    Replied to the thread IMXRT1020 will not program on secondary pinmux.

    Post
    With this new version, using GDB Server, after an initial 'load' of an elf, 'start' or 'run' for the first time will result in a target disconnect. Restarting GDB Server and gdb allows normal operation thereafter. I cannot recreate the previously…
  • SEGGER - Fabian -

    Replied to the thread J-Link stuck in bootloader mode, won't update.

    Post
    Hi Hugo, Thank you for your inquiry. From what we can see, the J-Link seems to be defective. Could you please provide us with the serial number of this J-Link? I am asking because the the S/N you have added to your forum profile is from a unit which is…
  • jev -

    Posted the thread Macro expansion in include paths.

    Thread
    For my projects, I often use the SDK from my silliconvendor. This SDK is unpacked in a directory, named after the version of the SDK. Thus, for example: "lib/nRF5_SDK_15.3.0_59ac345". I want to define an SDK_ROOT macro in my project and refer to files…
  • SEGGER - Arne -

    Replied to the thread I2C programming EEprom with Flasher ATE.

    Post
    Hello Bjarne, maybe you'd need to download the recent version. Just put "24C512" into the device search mask: ibb.co/Rzvkdpd Best regards Arne
  • Ronald -

    Replied to the thread I2C programming EEprom with Flasher ATE.

    Post
    Thanks Arne The device is not at the list in Universal Flashloader App. Do I then need to make a custom flashloader? Thanks in advance Bjarne
  • SEGGER - Oliver -

    Replied to the thread [SOLVED] Flasher STM8 - Programming Self-Powered Device.

    Post
    Answered via mail. Summary: Flasher stand-alone power supply in the project settings was enabled by the customer by accident. Additional information: Quote: “The project settings override the Flasher default state (that is what you set with power…
  • Hello, we currently do not have an API in the Flasher Portable Plus to read an IDCODE from a file. Such an API is under development, but it does not have a high priority and I cannot give you a schedule. If you are interested in a faster development…
  • InfinitionIT -

    Posted the thread J-Link stuck in bootloader mode, won't update.

    Thread
    Hello, We have a problem with a J-Link Plus that we bought last year. Part number is 8.08.28, version is 10.1. Our problem is that the J-Link firmware fails to boot, so it falls back to a bootloader firmware that won't even accept USB connections,…
  • SEGGER - Nino -

    Replied to the thread Example for Interrupt in empower board.

    Post
    Hello, How to enable interrupts on your target device can be found in the corresponding target reference manual from NXP. This is a target specific questions which we can't provide information for. For Guides and Examplecode there are literally millions…
  • SEGGER - Arne -

    Replied to the thread I2C programming EEprom with Flasher ATE.

    Post
    Hello Bjarne, it is possible to directly program this EEPROM using the Universal Flashloader: segger.com/products/production…e/#universal-flash-loader (24C512 should work) It is also possible to indirectly program the EEPROM, but this requires a…
  • icwiener -

    Replied to the thread Import previously exported data graph in Ozone.

    Post
    Hi, I think I understand how snapshots are supposed to work now. Powerful tool. However, that's not what we would need. We would like to be able to fetch diagnostics data with a computer sitting in production and then let the analysis happen on…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] How to use precompiled libraries.

    Post
    Hello Roger, Thank you for your inquiry. The Additional Input Files approach is the correct one. From the error message it appears that the target device you are using does not have a floating point unit but with the library you are trying to generate…