Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • pgherardi -

    Replied to the thread emVNC client.

    Post
    Any news ?
  • timurlocumi -

    Replied to the thread RTT slow not usable anymore.

    Post
    Sorry I did not get the Email Notification that you have replied. Regarding your questions: We have been using RTT Viever Mainly. And what ever is used within Segger Embedded Studio to show the RTT output. Both very laggy. Alternative for us is UART…
  • Barak14 -

    Replied to the thread RTT slow not usable anymore.

    Post
    I have been using the latest v6.42d and there is still a lot of lag in the RTT viewer compared to say v6.32i Actually I ran another test, 6.32i RTT Viewer is about 1000% faster than anything released after that - 6.42d and 6.43a are both hopelessly…
  • plainSpeak -

    Replied to the thread printf prevents UART app working when debugger not connected.

    Post
    Jev Belated thanks for the sound advice. Unfortunately it did not fix it. I found a similar suggestion from Nordic: devzone.nordicsemi.com/f/nordi…default_mode-blocking-app I get the same problem when I include the lines below in in sdk_config.h. The…
  • Please use the updated image of fail connection
  • Dear All We are using a simulation of A9 core based on Cadence Palladium, its identical to working with an actual A9 core except for speed. When connecting using 642d, the connection fails. See attached image for details. However When connecting using…
  • DG12 -

    Posted the thread J-Link command enhancement - trivial but very helpful null:= step.

    Thread
    As there seems to have been recent activity in the j-link application, I re-issue this request perhaps more nearly. When using j-link from the command line (like Mac OS terminal), pressing enter (without any other characters rather than moe, men, set,…
  • DG12 -

    Replied to the thread j-link list breakpoints.

    Post
    Using Mac OS with terminal for j-link there is no "web control panel" Seems like a really necessary missing command, i.e. LstBRK Thanks for you response.
  • Digilee -

    Posted the thread Alpha is displayed, but not image.

    Thread
    Hi, I am re-creating an old stemWin project, written using IAR by programmers no longer with the company, to the Atollic TrueStudio. I used CubeMX to create a simple window based on the Discovery32F429I board, which is a single layer, 565-based setup. I…
  • cvicens -

    Replied to the thread J-Link support for ZGM130S037HGN.

    Post
    Hi Nino, Thank you for your prompt reply. The ZGM130S037HGN is a Silicon Labs chip (like the EFM8) Segger also supports the EFR32FG13PxxxF512 from Silicon Labs. The core is an M4. I'll try the instructions that you provided for "Using a Precompiled…
  • Hello again! When using the assembly version V2.52f of SEGGER_RTT_WriteSkipNoLock, SystemView V2.52d stops with an "Invalid packet received" error. When SystemView recording starts for the first time, I get *some* correct records until the error…
  • SEGGER - Nino -

    Replied to the thread J-Trace and IAR.

    Post
    Hello Gawie, Yes IAR will utilize the 64 MB on board buffer so depending of the target speed and created trace data this can be enough to reconstruct the last couple of seconds. Best regards, Nino
  • Niob -

    Posted the thread Loadbin not working on ATSAMR21E19A.

    Thread
    Hello, I'm unable to use loadbin on an ATSAMR21E19A. I'm able to manually write and read memory but not using loadbin. Logs: Source Code (56 lines) Brainfuck Source Code (57 lines)Binary was compiled using Atmel Studio 7 and also flashing directly…
  • thomask77 -

    Posted the thread GCC support missing in SEGGER_RTT_ASM_ARMv7M.s.

    Thread
    Hi! I just downloaded the new SystemView 2.52f, and tried to compile it using a GCC toolchain. Apparently, the assembly file misses support for GCC. The easy fix is to just use the same settings for clang and GCC: C Source Code (1 line) Otherwise, a…
  • gawied -

    Replied to the thread J-Trace and IAR.

    Post
    Hi Nino Thanks for your prompt response. Am I correct that the J-Trace has a 64 MB on-board trace buffer? If so, can one get IAR EWARM to work with that? The first J-Traces, without streaming trace, made use of a on-board buffer and it work quite well…
  • DSmidgit -

    Posted the thread J-FLASH not reading external memory LH75401.

    Thread
    Hi, I have a custom board with an old LH75401 processor and 2Mb of external Flash. When I try to connect to it soetimes connects but most of the time it does not. When it does it connects really slow. Even when i set j-flash to automatic speed. I can…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hello Dirk, Great to hear that you are up and running again. As the initial inquiry has been solved this thread will be closed now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Sow to determine MAC address used for SES License.

    Post
    Hi Russ, Oh OK, I assumed you already gave our sales team the MAC addresses, sorry for the confusion. When choosing the "right" MAC address we recommend choosing a physical one which is build into your PC, like the Ethernet controller or build in…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Ozone.

    Post
    Hello, Thank you for your inquiry. We received your inquiry via e-mail in parallel. For future inquiries please try to use only one contacting channel, otherwise it can happen that information gets lost between channels which can lead to unnecessarily…
  • SEGGER - Nino -

    Replied to the thread J-Trace and IAR.

    Post
    Hello, Thank you for your inquiry. IAR unfortunately does not support any streaming trace features. For the best trace experience we recommend using Ozone the J-Link debugger. It can be used for free with a J-Trace PRO and works with IAR output formats.…