Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • VANAJA -

    Posted the thread RISCV base timing information.

    Thread
    Respected sir, I am the new user of the Segger Embedded Studio, but the tool is superb as it is flexible for the beginners. I have executed the C application code using RISCV-ISA RV32IMAF and obtained the results. Based on which core, the base timing…
  • SEGGER - Florian -

    Replied to the thread Widget Edit display unexpected length string.

    Post
    Hi Ross Lee, if you leave out the Para element, the EDIT widget will have a default length of 8. That was indeed your mistake. Now if you want to increase the text length and add a longer text to your widget, you should call EDIT_SetMaxLen() before
  • SEGGER - Schoenen -

    Replied to the thread STM32F746G-Discovery.

    Post
    HI, Of course, _cbCallback and _cbDialog are just names and you can choose them freely. But, the callback set for a dialog receives a WM_INIT_DIALOG message after all its dialog elements are created. This gives you the chance to configure the different…
  • Ross Lee -

    Replied to the thread Widget Edit display unexpected length string.

    Post
    Hi, This issue is finally solved by changing the element Para of Edit in resource table. As said in datasheet of emwin " The element Para is used according to the parameter MaxLen of the function EDIT_CreateEx()." Original code: Source Code (1…
  • lukma -

    Replied to the thread Relocate symbols in OZONE.

    Post
    Thanks for the hint. I was just curious - how one can load re-located U-Boot symbols (or shared library for example). In my use case - I would like to do it without any breakpoints set (HW or SW). Just break the execution of the code (at some random…
  • Hi, Thank you for your response. My approach (I think that it is what your suggested above): Power cycle the board Go to the U-Boot prompt > Start GDB server: ./JLinkGDBServerExe -select USB -device MCIMX6Q7 -endian little -if JTAG -speed auto -noir…
  • Sysmop226 -

    Replied to the thread emwin - GUI_LANG_LoadCSVEx loading different CSV files.

    Post
    Hi Florian, Thanks for the reply. I can reproduce the issue only with big CSV files. Source Code (3 lines)in test1 I get the number of languages in the file. in test2 I get 0 -> Failure. The CSV file (Array) is Valid, its a const array located on the…
  • Andrzej -

    Posted the thread STM32F746G-Discovery.

    Thread
    When to use _cbCallback and when _cbDialog?
  • v01d -

    Replied to the thread Relocate symbols in OZONE.

    Post
  • Interesting. So you saying, If I understand it right, it's coming out of reset but then is to quick for you to halt it ? Have you tried: connect to to the core, halt; set hardware bp at your wanted reset stop (0x908000 seems), reset the target &…
  • v01d -

    Replied to the thread RTOS plugin when no GDBServer used ( = IDE / tool uses jlink dll ).

    Post
    Quote: “How to use them is explained in Ozone manual. ” Does it mean I can use Ozone's plugin (so library) in another IDE? Just making sure I understand it. (Through a public available API to the RTOS's *.so ? or how ? )
  • v01d -

    Replied to the thread How to set JLink to never power the board.

    Post
    Hi, Quote: “Could you clarify which isolator you are currently using? ” USB Isolator -> segger.com/products/debug-prob…tors/j-link-usb-isolator/ Quote: “Does the same behavior occur when using another target board? ” Yes, I have purchased…
  • cymatics -

    Replied to the thread JLink EDU and Renesas HEW and E2 Studio.

    Post
    Thanks again. Were you ever able to find any potential solutions mentioned with using JLink with the RX and getting it working? It looks like i'm going to ask for a refund on the JLink Edu. The Renesas E2 Lite is a little cheaper than the Edu. Since…
  • cowens -

    Replied to the thread JLink EDU and Renesas HEW and E2 Studio.

    Post
    My experience is Segger points to Renesas and Renesas points to Segger. The JLink does work fine with arm based renesas cpus. The E1 debugger works without any issues out of the box with e2 studio and HEW.
  • cymatics -

    Replied to the thread JLink EDU and Renesas HEW and E2 Studio.

    Post
    Thank you for your reply. At least i know that i'm not the only one experiencing this. I have left messages on this Segger website as well as the Renesas website, but so far, i have not heard of any solutions (actually, yours is the first reply i've…
  • cowens -

    Replied to the thread JLink EDU and Renesas HEW and E2 Studio.

    Post
    I seem to recall similar experiences when attempting to use a JLink with a non-arm Renesas CPU. I tried for awhile to use a Jlink pro with a RX62N on e2 studio (version 7.0 I think -- maybe 6.2) and gave up and just went back to the Renesas E1. …
  • cymatics -

    Replied to the thread JLink EDU and Renesas HEW and E2 Studio.

    Post
    The full message i get in E2 Studio when the mouse pointer hovers over any particular PDR register settings is (eg): Failed to execute MI command: -data-evaluate-expression &(0xFFu) Error message from debugger back end: Attempt to take address of value…
  • cymatics -

    Replied to the thread JLink EDU and Renesas HEW and E2 Studio.

    Post
    I have been trying to modify the debug settings including GDB Server settings in E2 Studio, but i cannot get the emulator to actually upload the firmware to my board. However, i can toggle the IO register bits on the RX630 through the E2 interface.…
  • SEGGER - Fabian -

    Replied to the thread How to set JLink to never power the board.

    Post
    Hi, Could you clarify which isolator you are currently using? Does the same behavior occur when using another target board? Could you measure the voltage of the J-Link's 5V-pin when power off perm is used? Do you get the same Voltage reading…
  • SEGGER - Fabian -

    Replied to the thread Cortex M0 Downloading file Unspecified Error -1.

    Post
    Hi, Thanks for your inquiry. Could you please send us a J-Link log file? How to enable: wiki.segger.com/J-Link_DLL#Enable_J-Link_Log_File Could you also send us a screenshot of the full J-Link commander output? Could you also tell us, what chip exactly…