Thursday, April 26th 2018, 7:10pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

galaxyGuy

Beginner

Date of registration: Apr 23rd 2011

Posts: 3

1

Friday, May 6th 2011, 1:03am

[CLOSED]loadbin wth AT91M55800A & M29W800DB

I have managed to step through programming instructions in J-link and save my flash device content to file. I have also managed to manually perform a chip erase of the M29W800DB flash. The problem I am having now is that I cannot get the 'loadbin' command to write to the flash. The command seems to succeed, but when I read the flash content, it is still all 0xFF. I can manually implement the programming algorithm for the M29W800DB on a byte by byte basis, so I know that everything is working as it should be. I just need to know how to get the loadbin option to implement the correct algorithm.

On looking through the forum and documentation, I see that the 'exec' command is used to load flash device algorithm parameters. The trouble I have with this is that my flash is external and not on the supported list (although the list intimates that external devices are supported and do work). I tried "exec device = M29W800DB" and "exec device = AT91M55800A" , but although all these commands are accepted by J-link without error, they do not make any difference. The documentation lists "EnableFlashDL", but that's an unknown command in J-link.

T0CF0 7338:946 JLINK_IsHalted() returns TRUE
T0CF0 7338:948 JLINK_WriteMem(0x01000000, 0x100000 Bytes, ...) - Data: FF 1C 00 EA 10 B5 04 1C ...
T0CF0 7363:337 JLINK_ReadMemU16(0x01000000, 0x0100 Items, ...) - Data: FF FF FF FF FF FF FF FF ...


Regards,

This post has been edited 1 times, last edit by "galaxyGuy" (May 6th 2011, 8:28pm)


SEGGER - Alex

Super Moderator

Date of registration: Dec 18th 2007

Posts: 1,516

2

Friday, May 6th 2011, 12:58pm

Hi,

you are trying to program an external, CFI-compliant, NOR flash device.
The setup sequence for programming external CFI-compliant flash via the loadbin command is different from the sequence for internal flash.
For more information about how to setup J-Link commander for download into external CFI-compliant flash memory, please refer to
UM08001 Chapter 6.5 "Flash download and flash breakpoints" -> "Setup for different debuggers (CFI-flash)" --> "J-Link commander"


Best regards
Alex

galaxyGuy

Beginner

Date of registration: Apr 23rd 2011

Posts: 3

3

Friday, May 6th 2011, 8:28pm

Ahh, I missed that in the PDF manual... Tried just now and it worked.

Thanks for your assistance Alex.