Saturday, February 17th 2018, 8:17pm UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

gawied

Beginner

Date of registration: Jan 13th 2010

Posts: 3

1

Wednesday, October 6th 2010, 12:03pm

J-Trace M3 not enumerating

Hi

I used my J-Trace about a week ago and all was fine. Today, I re-connected my J-Trace and now it does not even try to enumerate. Only the Power led is on. I tried different USB cables, other PC's - nothing! My J-Link is still working fine.

Could it be something to do with v4.20g that I installed? This was the first time that I connected my J-Trace to my PC after I installed v4.20g of the J-Link driver. But now it do not even want to try to enumerate on any PC, regardless of the J-Link driver.

Is this the end of my J-Trace? ;(

Any help would be highly appreciated.

Regards,
Gawie

SEGGER - Alex

Super Moderator

Date of registration: Dec 18th 2007

Posts: 1,516

2

Wednesday, October 6th 2010, 3:53pm

Hi Gawie,

we are not aware of this kind of problems with V4.20g
Did you perform a firmware update after installing V4.20g?
If yes, was the firmware update successful or was there any error output?

Best regards
Alex

gawied

Beginner

Date of registration: Jan 13th 2010

Posts: 3

3

Wednesday, October 6th 2010, 6:23pm

Hi Alex

No, there was no firmware upgrade after I installed V4.20g. There was a fw upgarde early Sept (last month), but it worked fine afterwards.

I suspect that something went bad on the USB side as it does not even try to enumerate once connected - maybe some hardware fault ?( . But it is very funny - it was lying on my desk (unconnected) for about a week and when I connect it again, gone is the USB enumeration.

Any other suggestions or should I send it back for a replacement?

Regards,
Gawie