Friday, May 25th 2018, 2:58am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

anko

Beginner

Date of registration: Feb 14th 2018

Posts: 3

1

Wednesday, February 14th 2018, 9:06am

[SOLVED] How to avoid RAM initialization

Hi,
I am using J-Link and the GDB server for debugging ARM devices under Eclipse with GCC tool chain. I added external RAM to my linker script an realized that when loading my code with the debugger the complete external RAM section will be be loaded with data. Even though this RAM section does not need to be initialized with any data at all. I assume that J-Link is doing that for whatever reason. Is there a way to avoid that because it exceeds the download time quite significantly.

Any help on that is appreaciated.

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 1,054

2

Wednesday, February 14th 2018, 4:07pm

Hello,

Thank you for your inquiry.

Quoted

I assume that J-Link is doing that for whatever reason.

J-Link is doing that because Eclipse is telling J-Link to do so. J-Link will initialize and program any memory the IDE or program tells it to.
To avoid certain areas from being initialized you can tell J-Link to ignore them with command "map exclude".

More information can be found in the J-Link user manual.

Best regards,
Nino
Please read the forum rules before posting: Forum Rules

Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
Should you be entitled to support contact us per e-mail.
The following contact form can be used for this: https://www.segger.com/about-us/contact-us/


anko

Beginner

Date of registration: Feb 14th 2018

Posts: 3

3

Wednesday, February 14th 2018, 7:20pm

Hi Nino,

thanks for the valuable feedback. I checked the J-Link debugging configuration in Eclipse, but did not find the right place to put the "map exclude" command. Do you have a hint for that as well?

regards
Andreas

anko

Beginner

Date of registration: Feb 14th 2018

Posts: 3

4

Thursday, February 15th 2018, 8:19am

SOLVED

OK, I got it.
It has to be part of a J-Link script file. The script file can be passed by using the command line option -jlinkscriptfile which can be set in the eclipse debug configurations under the debugger tab.
See this link for instructions: https://wiki.segger.com/Eclipse#Using_J-Link_script_files

It works now as expected. Thanks again for pointing me to that

This post has been edited 1 times, last edit by "anko" (Feb 15th 2018, 8:21am)


SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 1,054

5

Thursday, February 15th 2018, 9:39am

Hello,

Great to hear that you are up and running again.
We will consider this case as closed now.

Best regards,
Nino
Please read the forum rules before posting: Forum Rules

Keep in mind, this is not a support forum. Its main purpose is user to user interaction.
Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
Should you be entitled to support contact us per e-mail.
The following contact form can be used for this: https://www.segger.com/about-us/contact-us/