Wednesday, May 23rd 2018, 1:03pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

kappah1984

Beginner

Date of registration: Jan 10th 2018

Posts: 1

1

Wednesday, January 10th 2018, 11:58am

files corrupted in Nand flash

Hello,

I have a problem of corrupted file in Nand flash: If I upload a file and read the file uploaded no problem but if I reboot my device and read the file uploaded previously the file is not the same.
Why this?

When I mounted this flash "TC58NVG1S3ETA00" the problem occurs rarely

• Organization
x8
Memory cell array 2112 × 128K × 8
Register 2112 × 8
Page size 2112 bytes
Block size (128K + 4K) bytes

but now with this new one "TC58NVG1S3HTA00" the problem occurs sistematically:

Organization
x8
Memory cell array 2176 x 128K x 8
Register 2176 x 8
Page size 2176 bytes
Block size (128K + 8K) bytes

SEGGER - Marius

Super Moderator

Date of registration: Aug 10th 2011

Posts: 32

2

Monday, January 15th 2018, 2:09pm

Hello,

There are many reasons why the file system gets corrupted.
The typical reason for the corruption of the file system stored
on a NAND flash is the occurrence of uncorrectable bit errors.
Bit errors can occur during the normal operation of the NAND flash
and ECC has to be employed to correct them. If more bit errors occur
than the ECC is able to correct the data gets corrupted.

The datasheet of the NAND flash documents how many bit errors
the ECC have to be able to correct in a specified data block.
These are ECC requirements for the NAND flash devices you are using:
"TC58NVG1S3ETA00" -> 1 bit / 512 bytes
"TC58NVG1S3HTA00" -> 8 bits / 512 bytes

The NAND driver has to be configured with the correct bit error correction
capability to ensure the correct operation.
Would it be possible to post your emFile configuration to have a look at it?
Thank you.

Best regards,
Marius