Friday, August 18th 2017, 11:53pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

masa

Beginner

Date of registration: May 10th 2017

Posts: 8

1

Tuesday, May 16th 2017, 3:03am

[SOLVED] Statiicaly global variables for OZone

Hi,

I am using OZone [V2.32].
I noticed that OZone can not distinguish static global variables of the same name while debugging.
My C program works fine, and I have analyzed the elf file and confirmed that there are no problems with the program.
Since there is no choice, this problem is avoided by changing to a unique name. Is there a good way to deal with the same name?

Regards,
Masa

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,568

2

Wednesday, August 9th 2017, 5:00pm

Hi Masa and Forum,


this issue should be resolved in the current version of Ozone .

Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link