Thursday, October 19th 2017, 4:24pm UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jperron

Beginner

Date of registration: Mar 16th 2017

Posts: 1

1

Friday, March 17th 2017, 2:17pm

[SOLVED] How do I disable the Flash Downloader in a JLINK.EXE command file?

Hi,

I am using JLINK.EXE (V6.14b) in batch processing mode (i.e.: I am feeding it a command file using the "-CommandFile <file>" argument when calling it from the command-line). I need to disable the Flash Downloader for what I am doing. I have tried using the "exec DisableFlashDL" command, but it does not seem to work. Despite calling "exec DisableFlashDL" from my script when it starts, JLINK.EXE still seems to notice if I write to an address mapped into internal flash space and automatically invokes the flash downloader which does an erase, program and verify (I can see this in the JLINK.EXE log which I enable using the "log" command in my script).

The only way I have been able to successfully disable the flash downloader is through the SEGGER J-Link Control panel GUI. If I go to the "Settings" tab and select the "Off" radio button under the "Flash download" section, the flash downloader is disabled. So now the first thing my script does is wait 10 seconds after connecting, which gives me time to open the control panel and hit the radio button to disable Flash Download. Yuck.

It seems like the "exec FlashDisableDL" command should do what I need, but it just isn't working for me. Has anybody else had this problem? Am I calling the command incorrectly?

I am using an Atmel SAM4C CPU, which is supported by the SEGGER tools.

Thanks,

Jason

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,684

2

Tuesday, March 28th 2017, 4:35pm

Hi Jason,

sorry for the delay in response.
We could reproduce this issue.
The "exec DisableFlashDL" should do the same as the J-Link control panel, but it currently does not.
We will fix this issue.
I will update this thread once a fixed version is available.


Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,684

3

Tuesday, April 4th 2017, 6:03pm

Hi Jason,


this issue is fixed in version 6.14c of the J-Link software & documentation pack.

Best regards,
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link