Wednesday, November 22nd 2017, 6:21am UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

honig

Beginner

Date of registration: Nov 16th 2015

Posts: 4

1

Wednesday, August 31st 2016, 11:36am

JLink (V6.00g, deb) Error: Could not connect to target

Dear all,

I could not connect my STM32F103ZE board and STM32F407VG Discovery board via Segger J-Link Plus (EDU version) on Ubuntu 14.04.5 LTS, while I can happily debug other boards on WIndows 7. ?(

Jlink Software packs I used are both of the latest version V6.00g.

Source code

1
$ JLinkGDBServer -device STM32F103ZE -if SWD -speed 1000


Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
SEGGER J-Link GDB Server V6.00g Command Line Version

JLinkARM.dll V6.00g (DLL compiled Aug 17 2016 13:20:32)

-----GDB Server start settings-----
GDBInit file:              	none
GDB Server Listening port: 	2331
SWO raw output listening port: 2332
Terminal I/O port:         	2333
Accept remote connection:  	yes
Generate logfile:          	off
Verify download:           	off
Init regs on start:        	off
Silent mode:               	off
Single run mode:           	off
Target connection timeout: 	0 ms
------J-Link related settings------
J-Link Host interface:     	USB
J-Link script:             	none
J-Link settings file:      	none
------Target related settings------
Target device:             	STM32F103ZE
Target interface:          	SWD
Target interface speed:    	1000kHz
Target endian:             	little

Connecting to J-Link...
J-Link is connected.
Firmware: J-Link V9 compiled Aug 17 2016 11:20:49
Hardware: V9.30
S/N: 269306079
OEM: SEGGER-EDU
Feature(s): FlashBP, GDB
Checking target voltage...
Target voltage: 3.28 V
Listening on TCP/IP port 2331
Connecting to target...ERROR: STM32: Connecting to CPU via connect under reset failed.
ERROR: STM32: Connecting to CPU via connect under reset failed.
ERROR: Could not connect to target.
Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...
Shutting down...
Could not connect to target.
Please check power, connection and settings.


Thank you and Best regards,
Honig

honig

Beginner

Date of registration: Nov 16th 2015

Posts: 4

2

Wednesday, August 31st 2016, 12:03pm

STM32F407VG Discovery Board

Source code

1
$ JLinkGDBServer -device STM32F407VG -if SWD


Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
SEGGER J-Link GDB Server V6.00g Command Line Version

JLinkARM.dll V6.00g (DLL compiled Aug 17 2016 13:20:32)

-----GDB Server start settings-----
GDBInit file:              	none
GDB Server Listening port: 	2331
SWO raw output listening port: 2332
Terminal I/O port:         	2333
Accept remote connection:  	yes
Generate logfile:          	off
Verify download:           	off
Init regs on start:        	off
Silent mode:               	off
Single run mode:           	off
Target connection timeout: 	0 ms
------J-Link related settings------
J-Link Host interface:     	USB
J-Link script:             	none
J-Link settings file:      	none
------Target related settings------
Target device:             	STM32F407VG
Target interface:          	SWD
Target interface speed:    	1000kHz
Target endian:             	little

Connecting to J-Link...
J-Link is connected.
Firmware: J-Link V9 compiled Aug 17 2016 11:20:49
Hardware: V9.30
S/N: 269306079
OEM: SEGGER-EDU
Feature(s): FlashBP, GDB
Checking target voltage...
Target voltage: 3.29 V
Listening on TCP/IP port 2331
Connecting to target...Connected to target
Waiting for GDB connection...


still Waiting ... for over 30 min.

Thank you and Best regards,
Honig

honig

Beginner

Date of registration: Nov 16th 2015

Posts: 4

3

Wednesday, August 31st 2016, 4:29pm

Update 1

Dear all,

Downloaded (V512j, .deb) , remove V600g and install this older version.

STM32F4Disc Board connected successful, step into Debug perspective in Eclipse.

STM32F103 still not work, the same error message as before:

Source code

1
2
3
ERROR: STM32: Connecting to CPU via connect under reset failed.
ERROR: STM32: Connecting to CPU via connect under reset failed.
ERROR: Could not connect to target.

SEGGER - Niklas

Super Moderator

Date of registration: Oct 6th 2014

Posts: 1,691

4

Wednesday, November 30th 2016, 11:55am

Hi,

We are not aware of any issues with ST STM32F4 or ST STM32F1 series devices.
According to your latest update, you are up and running with the ST STM32F4 board, correct?

Regarding ST STM32F103:
Do you use a custom hardware or an evaluation board? In latter case, which one?
Can you please give it a try using the latest version V6.12? The version is available for download here: https://www.segger.com/downloads/jlink
Please follow the instructions from the following troubleshoot article: https://wiki.segger.com/J-Link_can%27t_c…rget_connection
If you run into any issues, please provide us the screenshot of the entire J-Link Commander output.


Best regards
Niklas
Would you like to be added to the J-Link software update notification list, so you get informed automatically when a new version becomes available?
Just write me a PM or in case you want to subscribe to it yourself, please use this link: Link
Notification for J-Link, J-Link Debugger, SystemView & J-Scope: Link
Notification for Embedded Studio: Link