Thursday, May 24th 2018, 8:26am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

AF1

Beginner

Date of registration: Feb 2nd 2016

Posts: 9

1

Thursday, May 5th 2016, 4:06am

Problem with Hide and Show Windows

Hi

I seem to have problem with WM_HideWindow() and WM_ShowWindow() APIs.

I have created 2 windows (HomeWindow and SettingWindow) and each of the windows have multiple child widgets. When I try to hide HomeWindow and show the SettingWindow, the child widgets of the HomeWindow are still seen in the background.

Is there a way I can get show and hide windows including their child widgets?

Thanks
Aquib

Frost

Beginner

Date of registration: May 6th 2016

Posts: 11

2

Tuesday, May 10th 2016, 9:10am

Did you ensure that the widget of HomeWindow were created with the right parent (namely the HomeWindow handle)?

AF1

Beginner

Date of registration: Feb 2nd 2016

Posts: 9

3

Tuesday, May 31st 2016, 1:51am

Hi Frost

Apologies for the late response. I stopped tracking the thread when there was no response for a few days.

Yes I have ensured that the widgets belong to the right parent Windows. I have passed that problem, by creating all Windows with WM_CF_HIDE flag and using WM_ShowWindow() & WM_HideWindow() in the callbacks.

Cheers
Aquib