Monday, May 21st 2018, 8:52am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

enz

Beginner

Date of registration: Jul 23rd 2013

Posts: 33

1

Tuesday, April 26th 2016, 12:54pm

Connect to existing debug session not available

Hello All,

i am currently evaluating SystemView and found something strange.

I am using J-Link Pro and the device is a STM32F071CB.
When I have an active debug session via Ozone, then "Target | Start Recording" in SystemViewer 2.34 does not enable the button "Existing session", instead it is greyed out. Connection to J-Link is via TCP/IP.

As far as I read in the SystemView documentation, using an existing Debug session should be possible.

Am I mising something?

Edit:
I found another issue: The time scale is wrong (at least for the ISRs). The period of the SysTick is in reality 1ms, nut is shown in SystemViewer witth 1m29s (in words, 1minute 29seconds)!
The duration of the SysTick ISR is also to high. It is shown as 1.0172ms, while it really is only a few microseconds.

Best regards,
Martin

This post has been edited 1 times, last edit by "enz" (Apr 26th 2016, 3:41pm)


SEGGER - Johannes

Super Moderator

Date of registration: Aug 31st 2012

Posts: 379

2

Thursday, April 28th 2016, 7:10pm

Hi Martin,

Existing session is not available, yet. It will be enabled in a future version of SystemViewer.

If the time scale is wrong,
either the configured system and timestamp frequency is incorrect,
or if you see jumps in the SysTick interrupt, the GetTimestamp function is incorrect.

Which OS are you using?

Best regards
Johannes

enz

Beginner

Date of registration: Jul 23rd 2013

Posts: 33

3

Friday, April 29th 2016, 12:12pm

Hi Johannes,

thanks for the response.

With regard to the SystemViewer manual (UM8027; Rev.0 from 1. April 2016) I got the impression that Existing session is already available, Quote from the manual page 38:
"Note: SystemViewer can be used parallel to a debugger. In this case recording can be done
while the debugger is running. Make sure all required configuration is done in the debugger."

Is there a schedule, when this feature will be enabled?


I solved the issue with the timestamp. The RTOS used is FreeRTOS and the SystemViewer manual says that: "the SysTick handler
should increment SEGGER_SYSVIEW_TickCnt" so I incremented it in "vApplicationTickHook". After examining the code (which would be much easier if a parallel debug connection could be used ;) ) I realized that it must be incremented at the beginning of the Systick handler, before any trace macro is called. If SEGGER_SYSVIEW_TickCnt is incemented in "vApplicationTickHook", then the "traceISR_ENTER" is already called and the time calculation is wrong.

Maybe the manual could be improved be pointing this out more explicitly.

Best regards,
Martin

SEGGER - Johannes

Super Moderator

Date of registration: Aug 31st 2012

Posts: 379

4

Thursday, May 12th 2016, 11:30am

Hi Martin,

SystemViewer in genral can already be used in parallel to a debugger without the existing session option,
it will do this implicitly then.

The sample code for SEGGER_SYSVIEW_TickCnt describes,
that the increment needs to be done at the very first beginning of the tick interrupt, before creating any SystemView event.

Best regards
Johannes

enz

Beginner

Date of registration: Jul 23rd 2013

Posts: 33

5

Wednesday, June 1st 2016, 12:08pm

Hi Johannes,

this
SystemViewer in genral can already be used in parallel to a debugger without the existing session option,
it will do this implicitly then.
works only if the J-Link is connected via USB.

But I often use (and have to use) the Ethernet connection of my J-Link Pro. With this I get an error message "Max. number of connections exceeded" when I try to start recording.
Anything I can do about this, or is this behaviour intentional?

Best regards,
Martin

SEGGER - Johannes

Super Moderator

Date of registration: Aug 31st 2012

Posts: 379

6

Wednesday, June 1st 2016, 6:01pm

Mi Martin,

With the J-Link connected via Ethernet there is only one connection possible.
In this case you will have to wait for the explicit attach to running session option.

Best regards
Johannes