Thursday, November 23rd 2017, 5:44pm UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

baev_al

Beginner

Date of registration: Dec 25th 2014

Posts: 16

1

Monday, November 30th 2015, 10:37pm

STM32F103 + ST7735 + STemWin

Hello friends.
Can you please show me the way so I can use the STemWin with the attached schematic.
I searched the manual and compared with the examples included to the library. But I still didn't understand how all that was done.
I would appreciate if somebody would give me the exact steps which I should learn and understand to be able to adapt the library.
Thanks!
baev_al has attached the following image:
  • mcu.jpg

baev_al

Beginner

Date of registration: Dec 25th 2014

Posts: 16

2

Tuesday, December 15th 2015, 11:19pm

The program stucks at the B.N instruction. What mistake did I made?
PS. I didn't include any part of a program because I don't know what is needed. Just tell me.
I put breakpoints near LCD_X_Config(), LCD_X_DisplayDriver() and GUI_X_Config(). After stepping into GUI_Init function program never reachs any of the above functions. At the beggingin of compilling I receive a message that some breakpoints cannot be reached.
Thanks!

This post has been edited 1 times, last edit by "baev_al" (Dec 16th 2015, 4:42pm)


baev_al

Beginner

Date of registration: Dec 25th 2014

Posts: 16

3

Friday, July 29th 2016, 10:25am

I try to test classical example (Hello world text).

GUI_Init();
GUI_SetColor(GUI_WHITE);
GUI_DrawLine(0, 0, 150, 150);
GUI_DispString("Hello world");

However the above code does nothing.
The initialization of the display is ok (I draw two squares with different colors without stemwin).
I took LCDConf_FlexColor template and added my functions for LcdWriteReg, LcdWriteData and LcdWriteDataMultiple.
I do not use external ROM so I changed the value of memory in GUIconf.c to 0x1000. Is it ok?
Where I should point out that I use exactly ST7735 display?
Thanks.

This post has been edited 1 times, last edit by "baev_al" (Jul 29th 2016, 1:23pm)


rapid84

Beginner

Date of registration: Apr 15th 2016

Posts: 5

4

Friday, August 5th 2016, 3:27pm

how can you draw two squares without stemwin ? which fuctions did you use?