Sunday, April 22nd 2018, 6:52am UTC+2

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

tsaG

Beginner

Date of registration: Oct 29th 2014

Posts: 1

1

Wednesday, October 29th 2014, 3:57pm

Problem with connecting J-Flash to core

Hi!

Im Using an J-Link EDU for flashing an Atmel SAM3X8E. Im using Atmel Studio to write my code and flash it as well, no problem so far. Now I wanted to program it using another PC and tried using J-Flash since it is already included into the J-Link Driver.
When I click connect, it takes some time and then I get the following Error message:

Source code

1
2
3
4
5
6
7
8
9
10
11
- Connecting via USB to J-Link device 0
 - J-Link firmware: V1.20 (J-Link ARM V8 compiled Sep 22 2014 23:26:43)
 - Target interface speed: 2000 kHz (Auto)
 - Initializing CPU core (Init sequence) ...
    - Initialized successfully
 - Target interface speed: 2000 kHz (Auto)
 - Reading CFI info ...
    - Could not find CFI compliant flash device
 - Detecting flash memory ...
    - ERROR: Could not find any flash devices
 - ERROR: Failed to connect


This is the same error I get on my main computer where I can flash my device using atmel Studio. Im using SWD.
Am I doing something wrong? Also, Is there a MAC tool available? Right now Im using Virtualbox which is a hassle to flash my chips.

Thanks in advance!

SEGGER - Alex

Super Moderator

Date of registration: Dec 18th 2007

Posts: 1,516

2

Friday, October 31st 2014, 8:25am

Hi,

I assume you are trying to program the internal flash of your SAM3X8.
If yes: Your J-Flash is *not* configured correctly.
You have to select the correct device in J-Flash (as you have to do in Atmel Studio as well...)
Sample project attached.

For Mac / Linux:
J-Flash is currently not available under these platforms but you can also program the internal flash via J-Link Commander:
https://www.segger.com/jlink-flash-downl…lopmentPurposes


- Alex
SEGGER - Alex has attached the following file:
  • ATSAM3X8E.zip (923 Byte - 272 times downloaded - Last download: Apr 20th 2018, 2:13pm)