Monday, December 11th 2017, 5:59pm UTC+1

You are not logged in.

  • Login
  • Register

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Kristina

Beginner

Date of registration: May 7th 2012

Posts: 3

1

Monday, May 7th 2012, 6:10pm

[SOLVED]'start application' in Stand Alone mode

Flasher ARM: Stand alone mode does not execute 'start application' after programmingI configured 'Actions performed by "Auto" ' ticking Erase, Program, Start application in the Project settings window (Production tab). I start this with F7 in the JFlash environment and it works fine. The application starts after erasing and programming. After this, I downloaded the configuration to the Flasher. No error so far.

I start the stand alone programming by pressing the start button on the Flasher. The erasing and programming work fine but the application do not start after the programming finished.

What must I do to start up the target automatically after programming in stand alone mode?

Thank you.

SEGGER - Erik

Super Moderator

Date of registration: Dec 20th 2011

Posts: 392

2

Tuesday, May 8th 2012, 11:07am

Hi,

Could you please give us some information about your setup?
  • Which device (manufacturer + device name) do you use?
  • What SW version do you use?
Please note that the Flasher firmware that comes with SW V4.42 or later must be used in order to guarantee proper function of the start application command in stand alone mode. Please also note that the reset pin (nRESET) of the CPU also needs to be connected to the JTAG/SWD connector so the Flasher can toggle this pin.

Best regards,
Erik

Kristina

Beginner

Date of registration: May 7th 2012

Posts: 3

3

Wednesday, May 9th 2012, 9:19am

Hello,
I was using J-flash ARM v4.40d to programm freescale MK60N512VMD100 device. I'm using v4.46e sw version now and the problem is solved.

Thank you!

SEGGER - Alex

Super Moderator

Date of registration: Dec 18th 2007

Posts: 1,514

4

Thursday, May 10th 2012, 2:12pm

Hi,

Thanks for the feedback. Good to hear that everything works for you now.


Best regards
Alex