Saturday, February 24th 2018, 11:02pm UTC+1

You are not logged in.

  • Login
  • Register

pdoggett

Beginner

Date of registration: Feb 10th 2016

Posts: 2

1

Monday, February 12th 2018, 11:29pm

Flasher ARM V4 Secure Area create fail -262

Trying to use stand-alone mode. Flasher ARM hw version 4, s/n 164104208. Firmware compiled 2/12/2015 (distributed with J-Flash 5.10d). Running on Win7-32 PC.

Following instruction in users guide:
using J-Flash to save data & config to Flasher;
enter MSD mode to create _SECURE folder & move everything into it;
exit MSD mode;
connect via serial;
enter #AUTO.
Seeing $BTL log on serial console. "Trying to open firmware file... ERR: File not found."

Does not appear to enter stand-alone mode.

Used J-Link to issue "securearea remove" and "securearea create" but always get -262.

This used to work.

Tried going through Segger support, but Alex Gruner insists I cannot be having a problem.
pdoggett has attached the following file:

SEGGER - Erik

Super Moderator

Date of registration: Dec 20th 2011

Posts: 395

2

Thursday, February 22nd 2018, 9:22am

Hi,

We have fixed something related to the secure area in V6.20d of the J-Link software.
Can you please give this version a quick try and provide feedback? Please note that
for K60 series devices, you have to copy the DEVICE.PEX file located in the sub-directory FLASHER
as well to the _SECURE folder structure:
_SECURE\FLASHER.CFG
_SECURE\FLASHER.DAT
_SECURE\FLASHER (directory)
_SECURE\FLASHER\DEVICE.PEX

Short feedback would be appreciated.

Best regards
Erik