Friday, February 23rd 2018, 7:50am UTC+1

You are not logged in.

  • Login
  • Register

garrulous

Beginner

Date of registration: Feb 3rd 2018

Posts: 7

1

Wednesday, February 14th 2018, 11:41pm

Ozone: v2.56b on Lubuntu: Missing root forward-slash in file paths

Hello,

When using Ozone v2.56b on Lubuntu, Ozone can't find any source files referenced from the .elf file; looking at the "Source" pane, file paths are missing the root forward-slash.
Root forward-slash was displayed in v2.54b, and source files were found correctly.

Screenshot attached.
garrulous has attached the following image:
  • screenshot.png

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 716

2

Thursday, February 15th 2018, 9:01am

Hello,

Thank you for your inquiry.
Did you move the project around by any chance or renamed folders?
To keep your project portable you can use function Project.AddPathSubstitute.
How to invoke it correctly is described int he Ozone user manual.

Simply open your .jdebug file and add Project.AddPathSubstitute to function OnProjectLoad();

Does that resolve the issue?

Best regards,
Nino

garrulous

Beginner

Date of registration: Feb 3rd 2018

Posts: 7

3

Friday, February 16th 2018, 3:20am

Hi Nino,

Thanks for your reply, I will investigate Project.AddPathSubstitute().

Please note I still believe this to be a bug, as I can make the problem recur or go away just by upgrading/downgrading Ozone, between versions v2.54b and v2.56b, loading the same .jdebug file each time.

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 716

4

Monday, February 19th 2018, 8:44am

Hi,

It seems that under certain circumstances the leading slash would disappear in the Linux version.
This should be fixed now with the latest Ozone release: https://www.segger.com/downloads/jlink/#Ozone
Could you try it out and give feedback if the issue is resolved for you as well?

Best regards,
Nino