Monday, January 22nd 2018, 11:01pm UTC+1

You are not logged in.

  • Login
  • Register

kbb64

Beginner

Date of registration: Dec 20th 2017

Posts: 5

1

Wednesday, December 20th 2017, 1:14pm

SES include directories

I added an include directory in the
Edit Options->Code->Preprocessor->User Include Directories

-I ..\..\..\..\..\nRF5_SDK_14_A\components\libraries\fifo


try the build again with the same failure.

Looked in the project.emProject file and noticed that the include file was added the wrong way:
-I ..\\..\\..\\..\\..\\nRF5_SDK_14_A\\components\\libraries\\fifo;

remove the extra back slashes and it builds!
-I ..\..\..\..\..\nRF5_SDK_14_A\components\libraries\fifo

Then when I use Edit Options again it looks like the attached png file --

How do I easily fix this?

won't import windows include directories properly
kbb64 has attached the following image:
  • ses6.png

This post has been edited 2 times, last edit by "kbb64" (Dec 20th 2017, 1:37pm)


SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 567

2

Wednesday, December 20th 2017, 1:47pm

Hi,

Thank you for your inquiry.
The -I option is not required here, only add the path.
Does that solve the issue with the double backspaces?
If not try using forward slashes instead "/".

Best regards,
Nino

kbb64

Beginner

Date of registration: Dec 20th 2017

Posts: 5

3

Wednesday, December 20th 2017, 7:04pm

No that does not fix it: I am using version 3.34

Also it does not save it

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 567

4

Friday, December 22nd 2017, 3:12pm

Hello,

Looking at the screenshot your provided your user include paths look very wrong.
They should be looking like in the picture I have attached to this post.
Make sure to insert only one path per line and do not enter anything else than the path. No options, parameters, special symbols, nothing...

Does it work then?
If not could you attach your emproject file?

Best regards,
Nino
SEGGER - Nino has attached the following image:
  • Capture.PNG