Monday, January 22nd 2018, 10:49pm UTC+1

You are not logged in.

  • Login
  • Register

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 76

1

Friday, December 15th 2017, 9:21am

uploading & debugging Externally Built Executable project

So I tried this, for specified target iMX7D, A7_0 I selected.

I specified a bin file, tried debug loading it, it asked me for load address , I spec'ed 0x80000000 (DDR) , and then I get error

"0x80000000 - 0x800E5E93 load section does not fit the target description"

The section it's showing is just matching the size of the bin file. The DDR is well much larger than that.

Why is it complaining?

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 76

2

Tuesday, December 19th 2017, 1:42am

Any update, Nino?


With Eclipse, I was able to do this within 5 minutes. Please provide some steps to do this with ES.

SEGGER - Nino

Super Moderator

Date of registration: Jan 2nd 2017

Posts: 567

3

Tuesday, December 19th 2017, 9:50am

Hi,

Keep in mind that this is *not* a support forum.
Quote from our TOS:

Quoted

This forum is not monitored by SEGGER technical support personnel. Do not expect to receive technical support via this forum.

If you do not agree with this do not use the forum for support requests.

Now back to your question.

Quoted

I specified a bin file, tried debug loading it, it asked me for load address , I spec'ed 0x80000000 (DDR) , and then I get error

Where did you specify the bin file?
When did it ask you for an address?
Is the address part of the memory map of the device?

Best regards,
Nino

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 76

4

Wednesday, December 20th 2017, 2:37am

Hi,

Quoted

Keep in mind that this is *not* a support forum.
Yes, I was told multiple times, so I acknowledge I was informed about it. I didn't find I'm overusing or abusing the forum.
However, I''ll note that me/we in process of deciding if we will pay for ES license(s), so trying to save time getting all setup with ES to see it does all needed.

I'll get back to your questions on my actual question in a flash after I checked it.

v01d

Beginner

Date of registration: Feb 29th 2016

Posts: 76

5

Wednesday, December 20th 2017, 4:08am

Quoted

Where did you specify the bin file?

Project Options -> Debug -> Loader
-> Load file
I spec'ed complete path to the externally built *bin file

Quoted

Where did you specify the bin file?

Project Options -> Debug -> Loader

-> Load File Address
I put the address I want to load this to (as posted originally, in DDR , tested 0x80000000 or 0x87800000, depending on build)

Quoted

When did it ask you for an address?

It only asked if I left "Load File address" field (see above) empty. This was first time I started the debug session without setting that field. Then I've set it.

Quoted

Is the address part of the memory map of the device?
The address is valid by the iMX7D SoC manual. What map ES has for that I don't know / did not check, as I selected a supported device from list of available in project configuration : Target device - MCIMX7D7_A7_0.


Now I tried also changing "Access Variables Within Memory Map Only " option to No. With same result.