Thursday, April 26th 2018, 6:48pm UTC+2

You are not logged in.

  • Login
  • Register

Search results

Search results 1-9 of 9.

Friday, March 9th 2018, 3:16am

Author: Geoff_S

[SOLVED] FreeRTOS v10 compatibility ?

I tried following the existing procedure (ie for FreeRTOS v9) to modify a FreeRTOS v10 installation, consisting of copying over the target source modules, adding SEGGER_SYSVIEW_Conf(); to main() and running the FreeRTOSV9_Core.patch over the v10 files. I encountered some minor errors during compilation indicating "xJustPeeking" was undeclared where used in SEGGER_SYSVIEW_FreeRTOS.h. This occurred in the "#define traceQUEUE_xxxx" lines 212 to 229. I replaced all of these defines with versions tak...

Wednesday, March 7th 2018, 9:06am

Author: Geoff_S

[SOLVED] FreeRTOS v10 compatibility ?

I have read (somewhere on McuOnEclipse ?) that SystemView v2.52 is not currently compatible with FreeRTOS 10. Can you provide any information on what changes need to be made to make it work with FreeRTOS v10 ?

Thursday, February 8th 2018, 12:43am

Author: Geoff_S

FRDM-KL28Z with current J-Link OpenSDA firmware

Hi Nino, Thanks for the update. We have noticed that the debug UART (virtual COM port) on the FRDM-KL28Z does not seem to work correctly when using the generic OpenSDA v2.1 firmware. Sometimes it adds a few random characters to the end of strings, sometimes it continuously sends out garbage characters. The board works fine with the DAPLink interface so we have reverted to that in the meantime. See attached examples (J-Link generic OpenSDA vs DAPLink rev 0242) - notice the additional characters "...

Wednesday, February 7th 2018, 11:27am

Author: Geoff_S

FRDM-KL28Z with current J-Link OpenSDA firmware

Thanks Nino. I will watch the release notes on new J-Link releases. While we have moved to custom KL28Z bare metal boards, we're still using a few FRDM-KL28Z boards for development so it would be nice to get an updated bootloader for them.

Saturday, December 23rd 2017, 1:21am

Author: Geoff_S

FRDM-KL28Z with current J-Link OpenSDA firmware

Hi Nino, Yes, my board works with the generic openSDA v2.1 firmware. I will continue using it until an updated v2.2 version is available. thanks Geoff

Wednesday, December 20th 2017, 4:50am

Author: Geoff_S

FRDM-KL28Z with current J-Link OpenSDA firmware

Hi Nino, I'm sorry to say that procedure does not work for me. It is what I have tried before several times, without success. But just to check, I have done them again, and reported the results below. - Connect FRDM Board to PC while holding reset button. Ok. - A Drive named BOOTLOADER showed up Board shows up as "MAINTENANCE". A device which appears as "BOOTLOADER" indicates it is running an outdated version of DapLink bootloader ! See the flow chart under "How to update your boards" at https:/...

Thursday, December 7th 2017, 12:47am

Author: Geoff_S

FRDM-KL28Z with current J-Link OpenSDA firmware

Thanks Nino, that makes sense. I don't think I can downgrade the OpenSDA bootloader to v2.0, but you should be able to upgrade v2.0 to v2.2 using the DAPLink image from mbed website (step 1 on following link) https://os.mbed.com/blog/entry/DAPLink-bootloader-update/

Wednesday, December 6th 2017, 1:01pm

Author: Geoff_S

FRDM-KL28Z with current J-Link OpenSDA firmware

No I did not try that version, since the FRDM-KL28Z runs OpenSDA v2.2 as shown on NXP's website https://www.nxp.com/support/developer-reā€¦adapter:OPENSDA I think perhaps your website is wrong if it is indicating it runs v2.0 ?

Wednesday, December 6th 2017, 12:03am

Author: Geoff_S

FRDM-KL28Z with current J-Link OpenSDA firmware

I have a new FRDM-KL28Z dev board which comes with the default DAPLink bootloader and OpenSDA v2.2 firmware. I am having problems loading the current J-Link OpenSDA firmware on it. If I power the board up into bootloader mode, copy the latest J-Link firmware (from the "J-Link OpenSDA - Board-Specific Firmwares" page for the FRDM-KL28Z board) on to it, when the board restarts it is still running the original OpenSDA v2.2 firmware and a J-Link debug probe is not available. The best I have been abl...