Saturday, February 24th 2018, 2:36pm UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 716.

Wednesday, February 21st 2018, 5:13pm

Author: SEGGER - Nino

Impossible to connect a RENESAS R5F51116 with JLINK (V6.30D).

Hello, Thank you for providing the additional information. It seems that the R5F51116 target device has some other sub family parameters than the other RX111 devices. Unfortunately we currently have only R5F51115 eval boards in house so we can't reproduce the issue here. Would it be an option for you to send us your R5F51116 hardware temporarily so we can fix the implementation? Best regards, Nino

Wednesday, February 21st 2018, 5:10pm

Author: SEGGER - Nino

Segger Flasher ARM can't connect to Cypress' PRoC CYBLE-022001-00

Hello Fred, The CYBLE device series is not officially supported. Selecting a "similar" device with same RAM/ROM will not do the trick as especially Cypress devices behave very different even within the same device family. When testing on a CYBLE-214009-EVAL board I could only connect to it if I selected generic Cortex-M0 as the target device. This should be working with your board currently as well. We will get in touch with Cypress as they usually provide the support files for J-Link and see if...

Wednesday, February 21st 2018, 4:59pm

Author: SEGGER - Nino

Timeout while checking target RAM, RAMCode did not respond in time in CrossWorks

Hello, Thank you for your inquiry. Such an issue is not known to us. The J-Link software version you are using is not up to date. Could you try the latest one and see if the issue resolves? Best regards, Nino

Wednesday, February 21st 2018, 4:58pm

Author: SEGGER - Nino

Having Hard Fault in Tiva Launchpad FreeRTOS with J-Link but works fine in ICDI

Hello, this issue has not to do with the J-Link itself but how IDEs are using J-Link. Attached is an example project for the eval board created with Embedded Studio using the CPU support package manager: https://www.segger.com/products/developm…gy/cpu-support/ You can also open the Ozone debugger project included in the folder: https://www.segger.com/products/developm…-link-debugger/ Is the example project working on your hardware? Does the issue happen only with FreeRTOS enabled? Do generic pro...

Wednesday, February 21st 2018, 4:30pm

Author: SEGGER - Nino

cannot stop processor in Crossworks

Hello, Could you send us an Crossworks example project where the issue is reproducible for an eval board? Best regards, Nino

Wednesday, February 21st 2018, 4:29pm

Author: SEGGER - Nino

Cannot connect to PIC32MZ2048EFM100 via ICSP

Hello Patryk, has the issue resolved in the meantime or does a connect still not work? If not we could offer to take a look on your setup. For this you would need to send in your complete setup so we would have a reproduction scenario. Because currently without reproduction there is not much we can do here. Best regards, Nino

Wednesday, February 21st 2018, 11:40am

Author: SEGGER - Nino

Impossible to connect a RENESAS R5F51116 with JLINK (V6.30D).

Hello Frantz, Thank you for your inquiry. Such an issue is not known to us. Could you tell us your S/N of the J-Link you are using? Are you using custom hardware or an eval board? If an eval board which one? Could you post a Commader output screenshot of the failed connection? https://wiki.segger.com/J-Link_cannot_co…-Link_Commander Could you provide us with a J-Link log file from the failed session? https://wiki.segger.com/Enable_J-Link_log_file Best regards, Nino

Wednesday, February 21st 2018, 10:20am

Author: SEGGER - Nino

[Ozone]SWO issue

Hi Paco, For reference you can use the following example project from Nordic SDK. https://download.segger.com/Nino/NordicSDK_SES.7z The download will be available for at least 24 h. The example under examples\ble_central\ble_app_blinky_c\pca10040\s132\ses There you will find a Ozone project which should run out of the box and configure SWO correctly. The sources are included so you can compare them with your project. Best regards, Nino

Wednesday, February 21st 2018, 8:57am

Author: SEGGER - Nino

[SOLVED] J-Link cannot connect to i.MX6ULL target

Hello Keishi, Great to hear that you are up and running again. We will consider this case as closed now. Best regards, Nino

Tuesday, February 20th 2018, 2:20pm

Author: SEGGER - Nino

Compile C without assembler conversion

Hello Ilkay, You can import MBED projects already. This needs to be done manually though. For an export function in MBED please contact ARM as this is not our decision to make. From our side this would of course be appreciated. Best regards, Nino

Tuesday, February 20th 2018, 1:55pm

Author: SEGGER - Nino

[Ozone]SWO issue

Hi Paco, Quoted Could you verify that this file is included in the "J-Link Software and Documentation pack for Linux"? Ok didn't have the information before that you are using Linux. In that case you need to do the "update" manually by moving the JLinkDevices.xml and Devices/ folder from the J-Link install folder to the Ozone install folder. Then the correct SWO sequence should be called when selecting a nRF52 device with Ozone. Best regards, Nino

Tuesday, February 20th 2018, 1:32pm

Author: SEGGER - Nino

[SOLVED] J-Link cannot connect to i.MX6ULL target

Hello Keishi, Thank you for your inquiry. You need to specify the exact device name. Currently you are trying to connect to a generic Cortex-A7 device which will not work. When Commander asks you for the device name you can either type "?" to get a list of supported devices or write it directly. The correct device names for imx devices can be found here: https://wiki.segger.com/IMX_Series_Devices Best regards, Nino

Tuesday, February 20th 2018, 10:58am

Author: SEGGER - Nino

Cannot use JLinkRemoteServer on linux from windows' Keil: Max. number of connections exceeded.

Hello Marc, You write that you use a JlinkRTTServer. Can you elaborate what exactly do you mean by this? I could not find any software called like this. Did you mean JLinkRemoteServer instead? Multiple connections to J-Link over RemoteServer or IP are currently not supported. This might be implemented in future if the commands come from the same client PC. What is triggering the second connection? You write that Keil is doing it but we are not aware of such behaviour. Could you post a J-Link log...

Tuesday, February 20th 2018, 10:36am

Author: SEGGER - Nino

[SOLVED] Can not find ICE-Pick (IDCODE mismatch)

Hello, Great to hear that you are up and running again. We will consider this case as closed now. Best regards, Nino

Tuesday, February 20th 2018, 10:35am

Author: SEGGER - Nino

Segger Flasher ARM can't connect to Cypress' PRoC CYBLE-022001-00

Hello Fred, Thank you for your inquiry. Such an issue is not known to us. Are you trying to program custom hardware or an eval board? What target device are you selecting for connection? Could you try to connect to the target device using the J-Link commander and post a screenshot of the connection? https://wiki.segger.com/J-Link_cannot_co…-Link_Commander Does that generally work? Could you attach the config file you are using for programming? Could you also attach a J-Link log file of the faili...

Tuesday, February 20th 2018, 9:49am

Author: SEGGER - Nino

[Ozone]SWO issue

Hi Paco, when using our software there is no ITM setting required from your application. It even will disable SWO connection in some cases. So remove any ITM settings from your code. To use SWO in Ozone make sure that you have run the JLinkDLLUpdater once from the J-Link software install folder. For this close any open Ozone window and apply the DLL update. Now you should see SWO automatically in Ozone when starting the debug session without needing to launch the Commander. Best regards, Nino

Tuesday, February 20th 2018, 8:28am

Author: SEGGER - Nino

Compile C without assembler conversion

Hi Ilkay, Quoted I wonder if it uses the same principle quietly? Correct, they use the same princible C->Assembler->Obj, but delete Assemlber files afterwards. So it only looks like the conversion is direct. Best regards, Nino

Monday, February 19th 2018, 11:48am

Author: SEGGER - Nino

Break on ARM hard fault?

Hello Mike, Thank you for your inquiry. To set breakpoints you can either use monitor commands or a JLinkScript which then gets passed to VisualGDB. The monitor command you could use here is "setbp". More information can be found in the J-Link user manual. Best regards, Nino

Monday, February 19th 2018, 11:41am

Author: SEGGER - Nino

[Ozone]SWO issue

Hello, Thank you for providing additional information. Now it makes more sense, I thought you were using the JLinkSWOViewer. Are you using the PCA10040 eval board or some other? Could you provide a example project where the issue is reproducible? Could you try the latest Ozone and J-Link software release version to make sure we are not hunting any bugs that have already been solved? https://www.segger.com/downloads/jlink/ Best regards, Nino

Monday, February 19th 2018, 10:49am

Author: SEGGER - Nino

JLinkExe fails to connect to CC3220SF

Hello, Thank you for your inquiry. The CC3220 device family is currently not supported by J-Link. Listings on our webpage are incorrect and will be removed. According to TI they were able to establish connection to the CC3220 device with the CC3200 JLinkScript. But this could not be reproduced on our side yet with the CC3220 Launchpad. For more information please get into contact with TI. Best regards, Nino