Sunday, February 18th 2018, 8:38pm UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 1,000. There are even more results, please redefine your search.

Monday, November 13th 2017, 9:16am

Author: SEGGER - Niklas

[ABANDONED] J-Link+ problem connecting to Raspberry Pi 3

Hi, Quoted Unfortunately i am not allowed to spend more time on this case as this is starting to stretch the boundaries of forum support. What Nino said does not contradict the fact that you are entitled for two years of mail support, starting with the date of purchase of the J-Link ULTRA+. Quoted It would have been nicer if Niklas had told me up front that SEGGER will not support Raspberry Pi even on J-Link Ultra+ I said: Quoted Cortex-A53 is currently not supported by J-Link. Support for ARMv8...

Wednesday, November 8th 2017, 10:01am

Author: SEGGER - Niklas

[SOLVED] J-link EDU defective after 6.20c

Hi Forum, this issue has been resolved via mail. Best regards, Niklas

Friday, November 3rd 2017, 10:17am

Author: SEGGER - Niklas

Fail to connect to Segger J-Link Pro with Ethernet connection, using TCP/IP

Hi, sorry for the delay in response. So we established that the simple setup (J-Link PRO/PLUS, Remote Server, and Client (J-Link Commander) in one place works for you when trying from home, but the same simple setup does not work when trying from inside your company's network. This indicates that the issue is caused by the company's network / firewall. If this cannot be changed by your Administrator, would it make sense to give a Laptop + LTE a try? Best regards, Niklas

Friday, November 3rd 2017, 9:52am

Author: SEGGER - Niklas

Cant connect to NUCLEO-H743ZI using JLink firmware on the OB ST-Link

Hi Evgeny, a NUCLEO-H743ZI board is on its way to us, but will not arrive before the end of next week. Once we get our hands on it, we will give it a try. In the mean time, could you give J-Link Commander a try and post a screenshot of its output? Best regards, Niklas

Friday, November 3rd 2017, 9:44am

Author: SEGGER - Niklas

[ABANDONED] J-Link OB on HOLT Development board; firmware update seems to have changed target and maybe serial number

Hi, there has been some issues with the vendor detection in the past. Could you please give the most recent version of the J-Link software & documentation pack a try and provide feedback if the issue persists? Best regards, Niklas

Friday, November 3rd 2017, 9:35am

Author: SEGGER - Niklas

[ABANDONED] JLink overwriting RAM of STM32

Hi, Quoted Am I missing something or is this an inbuilt feature of JLink ? I am not aware of this "feature". Can you please tell me which target mcu you are using, and provide me detailed instructions on how to reproduce this issue? (Which ram address do you write, how do you read it back, etc....) Best regards, Niklas

Friday, November 3rd 2017, 9:31am

Author: SEGGER - Niklas

[SOLVED] Cant do anything with ATSAM4N16B

Hi, thanks for the update. Good to hear that it works for you when using Keil uVision. FYI: J-Link Plus and higher come with a license for Ozone - the J-Link Debugger, which can be used with an .elf file build by almost any compiler. Best regards, Niklas

Wednesday, October 18th 2017, 4:15pm

Author: SEGGER - Niklas

[ABANDONED] Command implementation through dll with the Segger J-Link Plus

Hi, I do not understand what you mean with the term "implementation of commands via dll". Best regards, Niklas

Wednesday, October 18th 2017, 11:31am

Author: SEGGER - Niklas

[ABANDONED] j-Link can't halt the Cortex-M3 CPU

Hi, I could not reproduce any issue with an empty device / generic target application. Can you provide is with a target application in order to reproduce the issue? Do you use low power modes in the application? Does the target application constrain the debug unit of the target device in any way? Best regards, Niklas

Wednesday, October 18th 2017, 11:28am

Author: SEGGER - Niklas

[ABANDONED] J-Link SWO Viewer will lost first few characters

Hi, can you provide us with a reproducer? Which target device do you use? Could you please provide us with the S/N of your J-Link? Best regards, Niklas

Wednesday, October 18th 2017, 10:02am

Author: SEGGER - Niklas

[ABANDONED] J-Link+ problem connecting to Raspberry Pi 3

Hi, Quoted if I tried to specify Cortex-A7 to JLinkExe against Cortex-A53 chip (like the BCM2837 on RPi3) As I said before, and do not see how this is supposed to work. Cortex-A53 has different and more registers, and is most likely different in many other ways (I myself have not yet worked with Cortex-A53). Quoted What does Cortex-A7 mean to JLinkExe? Specifying a core to the J-Link software allows the J-Link to make assumptions necessary to connect to the target and allow basic debugging (like...

Wednesday, October 18th 2017, 9:16am

Author: SEGGER - Niklas

[ABANDONED] How to exec command strings in Eclipse?

Hi, Let me rephrase that: The SetResetType command is not deprecated, but we have not added any new ResetTypes in a long time and also do not plan to add new ones in the future. If a new devices does not work with the generic reset, in 80% of the cases it needs a custom reset, which fits no other device. Therefore, we implement a custom reset which is not selected by the user, but is selected automatically when selecting the device in the J-Link software. However, if SetResetType=4 works perfect...

Tuesday, October 17th 2017, 5:19pm

Author: SEGGER - Niklas

[ABANDONED] JFLASH Error:could not perform target reset

Hi, could you please provide us with the serial number of your SEGGER product? Could you please provide us with a screenshot of J-Flash? Best regards, Niklas

Tuesday, October 17th 2017, 5:15pm

Author: SEGGER - Niklas

[ABANDONED] J-Link+ problem connecting to Raspberry Pi 3

Hi, It seems very unlikely to me that they are still selling v1. In case of doubt, I would ask them via mail / phone if they can tell you the hardware version or the first 4 digits of a serial number. As an alternative, it is possible to order directly from SEGGER: http://shop.segger.com/J_Link_ULTRA_p/8.16.28.htm [EU] http://shop-us.segger.com/J_Link_ULTRA_p/8.16.28.htm [US] Best regards, Niklas

Tuesday, October 17th 2017, 4:20pm

Author: SEGGER - Niklas

[ABANDONED] JLinkGDBServer cannot reset and halt the CPU, while Ozone can

Hi, does it work for you when using the most recent J-Link version? Best regards, Niklas

Tuesday, October 17th 2017, 3:07pm

Author: SEGGER - Niklas

[SOLVED] Burn hex file using Jflash into DA1580 Device

Hi Ezza, Quoted All fine, I understood now, the problem si that the DA14580 does not have a flash. As far as I know, it can be ordered with Flash or OTP memory. Do you want to explain the task you need to do? (Why do you want to download the .hex file? For debugging / testing?) Or is everything fine, as you said? Best regards, Niklas

Tuesday, October 17th 2017, 3:03pm

Author: SEGGER - Niklas

[SOLVED] [ARM] Running the JLinkGDBServer program on Raspberry Pi 3

Hi Henry, this thread was about running the J-Link software on a Raspberry Pi, but not about using a Raspberry Pi as a target device. Thanks for opening a dedicated thread for this issue. Best regards, Niklas

Tuesday, October 17th 2017, 2:39pm

Author: SEGGER - Niklas

[SOLVED] Burn hex file using Jflash into DA1580 Device

Hi, J-Flash Lite is used for flash memory programming. RAM programming should be done by the debugger, e.g. Ozone, embedded Studio or J-Link Commander. Maybe I misunderstand your use case. Do you have a different use case than debugging for download to RAM? Best regards, Niklas

Tuesday, October 17th 2017, 2:10pm

Author: SEGGER - Niklas

[SOLVED] Break OpenFlashLoader at least since v6.20e for Cortex-R4

Hi, thanks for the feedback and good to hear that it works for you! Best regards, Niklas

Tuesday, October 17th 2017, 12:05pm

Author: SEGGER - Niklas

[SOLVED] Burn hex file using Jflash into DA1580 Device

Hi, Quoted This is a link for DA14850 device: https://www.dialog-semiconductor.com/pro…artbond-da14580 This is the DataSheet link: https://www.dialog-semiconductor.com/sit…4580_ds_3v4.pdf I am confused. You say "DA14850", but link to "DA14580". Is DA14580 correct? Best regards, Niklas