Monday, January 22nd 2018, 9:04pm UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 49.

Wednesday, January 10th 2018, 1:47am

Author: MatthewKyeo

Is creating a breakpoint with custom conditions available?

Thanks for your reply, Nino. I will try the BP expressions. In the meantime, I always felt cumbersome to execute Ozone when using SES 3. Are there any plans to integrate Ozone into SES? Maybe bringing Ozone's debugging features to SES will make SES 3 better.

Friday, January 5th 2018, 6:37am

Author: MatthewKyeo

Is creating a breakpoint with custom conditions available?

Hello, I'm Matthew. I'm using SEGGER ES v3.34 with Nordic's PCA10040 board. This board has an onboard J-Link. As shown from the above picture, the Visual Studio can configure breakpoints with various conditions. IAR EWARM can also configure conditional breakpoints, too. I wanted to configure something similar with SES. [attach]2216[/attach] 1. Is it possible to configure hit counts or special conditions with SES's breakpoints? I cannot find the way how. 2. Is it possible to configure data breakp...

Friday, January 5th 2018, 6:19am

Author: MatthewKyeo

How to dump float/int values from the memory?

Oh, I see what you mean. Is it possible to set a memory range to copy the memory area? Since I have a big array (32-bit float x 1024), selecting that region with a mouse is quite painful. I was hoping something similar to Keil's Save command (save filename address1 address2). This similar feature is not currently supported in ES, isn't it? Hope a similar feature to be added someday. Or should I use other tools like J-Mem or Ozone? -Regards, Matthew

Thursday, January 4th 2018, 2:54am

Author: MatthewKyeo

How to dump float/int values from the memory?

Quoted from "SEGGER - Johannes" The memory content can only be exported as text or binary data. Thanks, Johannes. Can you help me with the text exporting feature, please? I cannot find that from the manual. How can I export memory contents as text with ES? In the meantime, I will try the Watch-clipboard feature. -Warm Regards, Matthew

Thursday, January 4th 2018, 2:52am

Author: MatthewKyeo

[SOLVED] Comment block template available when creating new C C++ source files?

Hi, Johannes. At least my wishes are on the wishlist, that will do! Due to your team's effort, I will be more absorbed in ES's experience more and more. Thanks for your reply and happy new year!

Friday, December 29th 2017, 10:03am

Author: MatthewKyeo

How to dump float/int values from the memory?

Hi, I'm Matthew. I tried to search this memory dumping feature on the web, but I couldn't find it. I use 64-bit SES 3.30 on a 64-bit Windows 10 machine. C/C++ Source code 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 #define NUMBER_OF_SAMPLES 1024 typedef struct my_struct { float roll; float pitch; float yaw; float ax; float ay; float az; }my_struct_t; typedef union my_union { float raw_buffer[NUMBER_OF_SAMPLES][6]; my_struct_t samples[NUMBER_OF_SAMPLES]; }my_union_t; my_union_t m_...

Monday, December 25th 2017, 3:03pm

Author: MatthewKyeo

[SOLVED] Comment block template available when creating new C C++ source files?

Hi, I'm Matthew. I use - 64-bit SES 3.30 on 64-bit Windows 10 - J-Link Plus or onboard J-Link (Nordic's dev kits have a J-Link on the board itself) - J-Link 6.16h - Nordic's PCA10040 v1.1.1 board (this board uses nRF52832-QFAA MCU) [attach]2208[/attach] My teammates have adopted Doxygen recently. So I was looking for some convenient features from SES to insert Doxygen related comments. When I create a new C/C++ source/header file with SES, just like the above picture, a blank screen shows up. C/...

Tuesday, December 12th 2017, 11:36am

Author: MatthewKyeo

[SOLVED] Additional Load File does not exist error

Wow, Nino! That was unexpected. Thanks for your answer, it works now. [attach]2185[/attach] $(ProjectDir)/../../../../../../components/softdevice/s132/hex/s132_nrf52_5.0.0_softdevice.hex was the answer. Problem solved! Appreciate your effort! -Regards, Matthew

Monday, December 11th 2017, 7:59pm

Author: MatthewKyeo

[SOLVED] Additional Load File does not exist error

Hi, I'm Matthew. I use - 64-bit SES 3.30 on 64-bit Windows 10 & MacOS (Nordic's free commercial license) - J-Link Plus or onboard J-Link (Nordic's dev kits have a J-Link on the board itself) - J-Link 6.22 - Nordic's PCA10040 v1.1.1 board (this board uses nRF52832-QFAA MCU) If I configure the path of the "Additional Load File[0]" as an absolute path, SES loads the hex file nicely. [attach]2182[/attach] Whereas when it is configured as a relative path, it shows the above error. [attach]2184[/attac...

Tuesday, December 5th 2017, 5:34pm

Author: MatthewKyeo

[SOLVED] Are there SystemView APIs when creating custom desktop GUI applications?

Thanks, Nino. DOC 13.3.4 RTT in other host applications RTT can also be integrated in any other PC application like a debugger or a data visualizer in either of two ways. • The application can establish a socket connection to the RTT Telnet Server which is opened on localhost:19021 when a J-Link connection is active. • The application creates its own connection to J-Link and uses the J-Link RTT API which is part of the J-Link SDK to directly configure and use RTT. The Nordic devzone also posted ...

Tuesday, December 5th 2017, 1:44am

Author: MatthewKyeo

[SOLVED] Are there SystemView APIs when creating custom desktop GUI applications?

Quoted from "SEGGER - Nino" If you want to use something like J-Scope that relies on high speed sampling (HSS) then you will need to purchase a J-Link SDK for your company: https://www.segger.com/products/debug-pr…/tools/j-scope/ Hi, Nino! I definitely don't need the HSS. Thanks for telling me. I have installed J-Link V6.22a, by the way. [attach]2147[/attach] About the source, are you mentioning these "SEGGER_RTT_XXX" API functions? I have understood that if I use the "SEGGER_RTT_printf()", a m...

Friday, December 1st 2017, 6:27pm

Author: MatthewKyeo

[SOLVED] Are there SystemView APIs when creating custom desktop GUI applications?

Hi, I'm Matthew. I use Nordic's PCA10040 (nRF-52 dev kit which has SEGGER's J-Link), and SES 3. I'm new to the SystemView so my idea might sound weird. Most of the time, people use UART/RS232 serial communication; a USB-UART converter to log or plot data. Using Qt5, the cross-platform GUI application framework, I wanted to draw a graph or a line chart after receiving data. However, each desktop OS required OS specific serial libraries. So I thought I can replace the UART serial communication to ...

Wednesday, October 25th 2017, 10:14am

Author: MatthewKyeo

[SOLVED] Question for startup code debugging and memory code size

Quoted from "SEGGER - Nino" The difference to the Output memory usage window is because the memory usage can be split differently depending on what method is used to calculate the values. If you sum both values up you will notice that they are actually equal. 75,7 + 13,4 = 80,4 + 8,7 Oh, I see. Come to think of it, the startup code has code to copy the ".data" from Flash to RAM . That calculation sure solved my mystery. Case complete! Thanks, Nino! -Best Regards

Wednesday, October 25th 2017, 9:48am

Author: MatthewKyeo

[SOLVED] Not possible to place a debug view into an empty dock while debugging

Quoted from "SEGGER - Nino" All you have to do is drag the "inner" icon that says "Memory Usage" and not the outer rim of the window. Woah. I see. I had a hard time understanding your words. Finally, I have merged them! Check my video ~. In my case, I haven't clicked the inner icon. If I clicked it, it shows options and it didn't make the window merge. So I clicked the bar where it has the inner icon. Thanks for solving this! One opinion here; in the next or future update on SES, can you change...

Wednesday, October 25th 2017, 6:40am

Author: MatthewKyeo

[SOLVED] Not possible to place a debug view into an empty dock while debugging

Hi, Nino! In my previous post, I used 64-bit SES 3.26 on 64-bit Windows 10. Now, I have updated SES to 3.30, as you see my shared video . However, the update didn't solve my problem. Both versions(3.26 and 3.30) showed the same result. Am I doing the wrong way? I failed to move the "Memory Usage" window to the "Locals" window. I have also uploaded my computer's information. Can you take a look, please? -Best Regards

Wednesday, October 25th 2017, 6:16am

Author: MatthewKyeo

[SOLVED] Question for startup code debugging and memory code size

Quoted from "SEGGER - Nino" - in the Project Explorer you will see iin the columns Code and Data how much of ceah is used total by each file. Best regards, Nino Wow, Thanks, Nino! 2 last questions, please. 1. About the "Code and Data" shown in the Project items columns, [attach]2043[/attach] I noticed that the size shown in the output window and the Project items columns are different. See the red mark; Output shows the code size is 80.4KB whereas the column shows 75.7KB. The purple section is ...

Tuesday, October 24th 2017, 9:19am

Author: MatthewKyeo

[SOLVED] Question for startup code debugging and memory code size

Hi, I'm Matthew. I use - 64-bit SES 3.26 on 64-bit Windows 10 - J-Link Plus or onboard J-Link (Nordic's dev kits have a J-Link on the board itself) - J-Link 6.16h - Nordic's PCA10040 v1.1.1 board (this board uses nRF52832-QFAA MCU) - STM32F4 Discovery board In the past, I used IAR EWARM 7 and Keil MDK 5. 1.IAR provides an option called "Run to main". If this is unchecked, the debugger starts from the startup code. Does SES has a feature to start debugging from the startup code? 2. After building...

Tuesday, October 24th 2017, 9:09am

Author: MatthewKyeo

[SOLVED] Not possible to place a debug view into an empty dock while debugging

Hi, I'm Matthew. I use - 64-bit SES 3.26 on 64-bit Windows 10 - J-Link Plus or onboard J-Link (Nordic's dev kits have a J-Link on the board itself) - J-Link 6.16h - Nordic's PCA10040 v1.1.1 board (this board uses nRF52832-QFAA MCU) - STM32F4 Discovery board I moved the "Memory Usage" view out from the dock. [attach]2031[/attach] I tried to place that inside the dock again. However, there were no blue boxes indicating whether the view is placeable or not. [attach]2032[/attach] For instance, if I ...

Tuesday, October 24th 2017, 8:56am

Author: MatthewKyeo

[SOLVED] How to make the linker write binary values in a flash memory using SES

Thanks to you both! Here's my result. I have used a JPG file instead of a WAV file. First, I checked the memory size and usage not to overlap my binary file. [attach]2028[/attach] So I configured the load file after checking the memory usage. [attach]2029[/attach] After flashing the MCU with the J-Link, the memory viewer shows the correct values! I used HxD to check the binary values. [attach]2030[/attach] Case solved! Thanks1 -Best Regards

Thursday, October 19th 2017, 10:06am

Author: MatthewKyeo

[SOLVED] How to make the linker write binary values in a flash memory using SES

Quoted from "SEGGER - Nino" You have two options here. 1. You set the wav file as an additional load fiel. To do so go to project options -> Debug->Loader here you edit Additional Load file [0] , type and address. Thanks. Then let's consider the Nordic's MCU case. [attach]2015[/attach] Nordic loads a hex image called SoftDevice. I use SoftDevice 5.0 . So I already filled a directory at the "Additional Load file [0]" field. According to from the specification, The SoftDevice Flash Region is loca...