Wednesday, December 13th 2017, 4:00pm UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 453.

Today, 3:12pm

Author: SEGGER - Nino

[SOLVED] JLinkARM_V482

Hello, We received your request per email. To make sure no information gets lost we will continue this request per email. Generally it is possible to provide older versions for some older setups. This thread will be closed now. Best regards, Nino

Today, 11:44am

Author: SEGGER - Nino

FRDM-KL28Z with current J-Link OpenSDA firmware

Hi, Quick update on my findings. I followed the instructions on our website: https://www.segger.com/products/debug-pr…-v2/#tab-3932-6 And downloaded the attached binary form our download section. To flash it the following steps were executed: - Connect FRDM Board to PC while holding reset button. - A Drive named BOOTLOADER showed up - Drag and drop attached binary onto BOOTLOADER drive - Wait till it dissapears - Power Board off and on - J-Link Connected successfully. Does that work with your bo...

Today, 11:17am

Author: SEGGER - Nino

error code -262

Hi, Thank you for providing the additional information. The error message displays because the emulator does not support creating and adding secure areas. Secure Area is supported since Flasher V4. We suggest upgrading your Flasher to a newer model. For this you can use our trade in program so you get a discount on your new purchase: https://www.segger.com/purchase/trade-in-program/ Best regards, Nino

Yesterday, 5:05pm

Author: SEGGER - Nino

[SOLVED] RTT: open telnet server for RTT channel 1?

Hello, Thank you for your inquiry. To be able to read RTT from other channels than 0 you correctly assume that you need the J-Link SDK for. The SDK needs to be acquired extra, then you will receive the example project and documentation etc.: https://www.segger.com/purchase/pricing/jlink-related/ Under position 8.08.06. Best regards, Nino

Yesterday, 5:03pm

Author: SEGGER - Nino

Where are JLink SDK example applications?

Hello, This question will be answered in your other post as the answer is the same for both questions: https://forum.segger.com/index.php?page=Thread&threadID=4718 This thread will be closed now. Best regards, Nino

Yesterday, 3:56pm

Author: SEGGER - Nino

error code -262

Hello Jokin, Thank you for your inquiry. What exactly is your setup? Could you provide the serial number of your Flasher? What target device are you trying to program? Could you attach your J-Flash project file? Best regards, Nino

Yesterday, 3:42pm

Author: SEGGER - Nino

[SOLVED] show print margin in code editor

Hello, Yes there is such an option. You can find it under: Tools->Options...->Text Editor->Languages->C and C++-> Column Guide Columns There you can set a fixed column where to draw a line. Is that what you were looking for? Best regards, Nino

Yesterday, 2:30pm

Author: SEGGER - Nino

[SOLVED] VCOM enable/disable issues with J-Link OB SAM3U

Hi Kostas, I have contacted you per email in this regard. This thread will be closed now. Best regards, Nino

Yesterday, 12:07pm

Author: SEGGER - Nino

[SOLVED] VCOM enable/disable issues with J-Link OB SAM3U

Hi Kostas, What board are you using and what target device are you trying to program with your OB? We will then investigate why VCOM was even disabled if this was originally part of the OB FW. Quoted Is there any sort of table of what each config byte does, or this is not public info? This is not public info as the user should never have to care what is written in there. Quoted Regarding these config bytes, I see that enabling/disabling the VCOM changes a different set of config bytes depending ...

Yesterday, 11:37am

Author: SEGGER - Nino

[SOLVED] Additional Load File does not exist error

Hi Matthew, Great to hear that you are up and running again. We will consider this case as solved now. Best regards, Nino

Yesterday, 10:20am

Author: SEGGER - Nino

Debugging issues in secure monitor mode

Hi Isiora, Thank you for providing the project. First i tried to reproduce the behaviour with Embedded Studio under windows loading your assembler file in a example project. But there was no error showing that a register could not be read. Quoted Moreover, executing the "mov r1, lr", you should able to see a strange and incorrect result: in r1 there is the value of r0, and not the value of lr. This was reproducible for me in my setup. You can avoid this if you turn off instruction set simulation...

Yesterday, 10:10am

Author: SEGGER - Nino

[SOLVED] Unable to debug Eclipse project on Linux using Jlink GDB server, Unable to halt target sama5d2

Hello, Thank you for your inquiry. You are using a V8 SAM-ICE which does not support Cortex-A5 debugging. I just tried to reproduce the issue with a SAMA5D2 xPlained eval board, a J-Link Plus and Software version V6.22c. Everything was working fine as expected. So we suggest upgrading it to a newer model thorough our trade in program: https://www.segger.com/purchase/trade-in-program/ Best regards, Nino

Yesterday, 9:56am

Author: SEGGER - Nino

[SOLVED] Additional Load File does not exist error

Hi Matthew, Thank you for your inquiry. To use the relative path to your hex please use the project directory macro as base. e.g. $(ProjectDir)../../../test.hex This is then relative to the .emProject file. Does that work for you? Best regards, Nino

Yesterday, 9:08am

Author: SEGGER - Nino

[SOLVED] VCOM enable/disable issues with J-Link OB SAM3U

Hello Kostas, Thank you for your inquiry. To enable VCOM permanently you can also use the J-Link Configurator. You can simply open the J-Link Configurator, double click your device and enable VCOM, then power the J-Link off and on and press ok. Now the VCOM setting should be memorized even after a power on reset. Does that solve the issue? Best regards, Nino

Monday, December 11th 2017, 5:25pm

Author: SEGGER - Nino

[SOLVED] Issues switching from ST-LINK to J-LINK

Hi, Great to hear that you are up and running again. Pins 3/5 are nTRST/TDI on the JTAG interface. By default nTRST is usually pulled high. If you pull it to ground J-Link will assume that the target is held in reset and can't connect. This thread will now be considered as solved. Best regards, Nino

Monday, December 11th 2017, 1:54pm

Author: SEGGER - Nino

[SOLVED] Issues switching from ST-LINK to J-LINK

Hello, I just tried to reproduce the issue with the NUCLEO-F746ZG eval board but everything working as expected. Could you check if your custom hardware has the debug interface wired like the NUCLEO-F746ZG? Is the J-Link generally working with other target devices/eval boards? Best regards, Nino

Monday, December 11th 2017, 1:44pm

Author: SEGGER - Nino

IAR with remote J-link ARM GDB server

Hello, Thank you for your inquiry. What exactly is your setup? Is your host PC the raspberry pi? How is the J-Link connected to it. Where is IAR installed and what version are you using? What exactly are you trying to achieve with your setup? Is the STM32 the target device you are trying to program? Best regards, Nino

Monday, December 11th 2017, 9:25am

Author: SEGGER - Nino

programming failed ATSAMD21G18 with SEGGER-EDU

Hello pak, Quoted Is it possible to restore the chip to the factory default by J-Link? We have no information about such a feature. Please contact Atmel for such information. So far we never needed to restore a chip because simply triggering the reset pin was enough. Quoted In case of ISP dose not work, I usually use "High Voltage Programmer" to restore the chip to factory default. According to the link a 12 V line is needed for this to work. J-Link can output maximum 5 V so this technique will ...