Wednesday, December 13th 2017, 8:16am UTC+1

You are not logged in.

  • Login
  • Register

Search results

Search results 1-5 of 5.

Wednesday, December 6th 2017, 4:26pm

Author: szoshi

Debugging external binary

Hello, I have had good success so far connecting a JLink to an ARM11 board and getting a flashing LED example to compile and execute on the board. I can also step through the program without any issues. I am now wondering if I can debug an externally built binary on my board. It is a small binary (less than 1k bytes) that I can flash to the RAM of the board. Since I don't have the source code though, I cannot step through the program. Is there a way where I can use the debugger to just step thro...

Wednesday, November 29th 2017, 12:20pm

Author: szoshi

[SOLVED] Debugging library functions

Thanks for the clarification. I was asking since I have had instances in the past (with other hardware/software) where faulty project settings were leading to malloc failing. Following the malloc code helped me to track my problem. I just wanted to check if there was something I was overlooking. Now that I know this I can try to debug my applications with a different approach.

Wednesday, November 29th 2017, 12:17pm

Author: szoshi

[SOLVED] Cortex A53 support?

That is great news Erik. I look forward to official notifications.

Tuesday, November 28th 2017, 1:55pm

Author: szoshi

[SOLVED] Cortex A53 support?

Hello, is the end of the year still the target date for A53 support? Regards, szoshi

Tuesday, November 28th 2017, 1:25pm

Author: szoshi

[SOLVED] Debugging library functions

Hello, I am playing around with the Embedded Studio and have been very impressed with what i have seen so far. I am still only using the simulator instead of actual hardware and had one question about the simulator. When i debug my application, I see that functions like malloc are directly linked to via pre compiled libraries. As a result, I cannot see where in source sode a problem occurs. I can step through the assembly code but that is not much help. Is there a way to force embedded studio to...