Sunday, September 24th 2017, 1:35am UTC+2

You are not logged in.

  • Login
  • Register

Search results

Search results 1-20 of 172.

Friday, September 22nd 2017, 9:07am

Author: SEGGER - Nino

Error just like Thread 4123 but now unknown EMU Command 26

Hello Tharon, The fix is applied and it will be available with today's release version. Sorry for any inconveniences caused. Would you like to be added to the J-Link software update notification list, so you get informed automatically when the new version becomes available? Subscribe: https://www.segger.com/notification/subs…php?prodid=7,94 Best regards, Nino

Wednesday, September 20th 2017, 5:46pm

Author: SEGGER - Nino

Further on Initializing QSPI on STM32F7

Hello Victor, Thank you for providing the log file. According to the log file no write to the QSPI Flash has happened. It seems that the compiler still does not link the array into the QSPI Flash. You can force the compiler to keep certain symbols. To force the array go to: Project Options > Linker > Keep Symbols Double click that entry and add "newMemory" without the quotation marks in a new line. Does that solve the issue? Could you provide me with an example project for an eval board with tha...

Wednesday, September 20th 2017, 5:40pm

Author: SEGGER - Nino

Error just like Thread 4123 but now unknown EMU Command 26

Hello Tharon, Yes i will inform you in this thread. We know where the issue is coming from but we had to finish other paid projects first before addressing this. Currently we are planing to include the fix in the next release version scheduled for the end of the week. Should we have something finished earlier we could provide you with a preliminary fixed version if you would be interested into this. Best regards, Nino

Wednesday, September 20th 2017, 4:42pm

Author: SEGGER - Nino

Further on Initializing QSPI on STM32F7

Hello Victor, Could you attach your J-Link Logfile after the download process? A how to is described here: https://wiki.segger.com/J-Link_DLL#Enable_J-Link_Log_File Best regards, Nino

Wednesday, September 20th 2017, 4:26pm

Author: SEGGER - Nino

Further on Initializing QSPI on STM32F7

Hello Victor, does your application initialise the QSPI Controller? Keep in mind that after the target download the J-Link Flashloader restores the previous QSPI and Clock registers. So if your application does not initialize the necessary registers you won't be able to execute code from QSPI Flash. Best regards, Nino

Wednesday, September 20th 2017, 3:23pm

Author: SEGGER - Nino

Further on Initializing QSPI on STM32F7

Hello Victor, The problem is that the way you are placing your array it is not being referenced anywhere. C/C++ Source code 1 2 __attribute__ ((section (".textqspi"))) uint32_t newMemory[4] = {1, 2, 3, 4} You need to reference/use "newMemory" somewhere otherwise the gcc compiler will "optimize" the array away as it is not being used. Best regards, Nino

Wednesday, September 20th 2017, 3:12pm

Author: SEGGER - Nino

Have to import cpp files to run code

Hello Øyvind, Quoted I also have another problem. I have installed "STLport Library Package" in order to include <iostream> and use to_string for example. Under tools>Show installed packages it is explained how to use STLPort: To get to the option you can either right click your project in the "Project Explorer" and select "Edit Options...". From there on navigate to the section "Libraries". There you can enable or disable the STLport Library. You can also use the "Search Options" function and t...

Tuesday, September 19th 2017, 3:35pm

Author: SEGGER - Nino

[SOLVED]Embedded Studio crashes on VMware VM

Hello Achim, Great to hear that you are up and running again. I will consider this case as closed now. Best regards, Nino

Tuesday, September 19th 2017, 9:41am

Author: SEGGER - Nino

-timeout parameter to JLinkGDBServer seems not working

Hello Denis, Your first question has been answered in the other thread. Quoted Is JLinkConfig part of the standard JLink installation? I cannot find this program in my Linux Segger installation. The JLinkConfig is only part of the Windows software package. Best regards, NIno

Tuesday, September 19th 2017, 8:58am

Author: SEGGER - Nino

Ozone for OSX key binding

Hello Ting, Thank you for your inquiry. The key bindings in Ozone are not configurable. Best regards, Nino

Monday, September 18th 2017, 4:44pm

Author: SEGGER - Nino

Further on Initializing QSPI on STM32F7

Hello Victor, The entries look correct to me. If everything is set up correctly you should now see your application placed in QSPI memory when building. Did you make sure the project uses them? In your project settings you can set it under "Memory Map File" and "Section Placement File". What target device are you trying to program? Which flash loader do you use? Could you attach your .emProject file so i can check if the project settings are set correctly? Best regards, Nino

Monday, September 18th 2017, 2:02pm

Author: SEGGER - Nino

Have to import cpp files to run code

Hello Øyvind, Thank you for your inquiry. The lcd.cpp file must be part of your project. Otherwise the linker can't find the functions that are referenced. So simply add it by e.g. drag and drop to your project tree. Best regards, Nino

Monday, September 18th 2017, 11:36am

Author: SEGGER - Nino

Tracing on a device that loses connection to CPU

Hello Bruno, Did you try the trace example project from the wiki? Is trace and the connection to the board working as expected in that example project? Best regards, Nino

Monday, September 18th 2017, 11:32am

Author: SEGGER - Nino

[CLOSED]Newbie needs help compiling project

Hello David, Your inquiry is already being handled via e-mail. Please refrain from opening multiple support requests as this will not increase our response time but rather delay it as we have to collect information now from several sources instead of from just one. This thread will now be closed and answered via e-mail. Best regards, Nino

Monday, September 18th 2017, 11:23am

Author: SEGGER - Nino

Using printf-debug with importet HAL-linbrary (STM32)

Hello Oliver, Sorry for the delay in response. Quoted But I miss the Debug-printf-function. I tried to copy and include all libraries from an ES-created project, but it does not work. I assume you want to use a printf function to output debug information on your terminal. What hardware interface are you using/ planning to use for that on your target interface? Via Semihosting, SWO, RTT? We recommend using RTT as you are hardware independend and faster than other printf style techniques. More inf...

Monday, September 18th 2017, 11:17am

Author: SEGGER - Nino

[SOLVED]Embedded Studio crashes on VMware VM

Hello Achim, Thank you for your inquiry. Such a behaviour is not known to us. I tried to reproduce the issue you were seeing, but Embedded Studio was starting just fine in the Ubuntu VM while my J-Link PRO was connected to it via USB. Have you installed the J-Link Software Package in your Linux VM? https://www.segger.com/downloads/jlink/ Are you using some kind of USB-Hub? Does the issue resolve when you connect directly to your PC without any hub in between? Best regards, Nino

Monday, September 18th 2017, 11:08am

Author: SEGGER - Nino

Further on Initializing QSPI on STM32F7

Hello Victor, Thank you for your inquiry. To address newly added external memory you need to edit the memory map file. Per default Embedded Studio is only addressing the internal memories as the external ones are not guaranteed to be there. So to add memory to your project simply right click your project in Embedded Studio and in the context menu select: Edit Memory Map After adding all required information in the .xml you need to adjust your section placement file accordingly. Open it just as t...

Monday, September 18th 2017, 11:01am

Author: SEGGER - Nino

OZONE how to load to QSPI flash on STM32F769_EVAL board

Hello Bruno, Quoted According to http://www.st.com/en/evaluation-tools/stm32f769i-eval.html, it comes with 512Mbit QSPI. I was using the FlashAlgo code I got originally from Segger. I've also built and run the FlashAlgo for 16 and 32 MBytes. You are correct. Sorry i was looking at the wrong IC. Quoted What adjustments are needed? I looked at the schematic, it appears the same pins are used as with the 769 eval board. And it appears in the JLinkDevices.xml. But I did have a problem with Eclipse a...

Thursday, September 14th 2017, 6:19pm

Author: SEGGER - Nino

OZONE how to load to QSPI flash on STM32F769_EVAL board

Hello Bruno, Quoted I created the flash loader myself with assistance from Segger Support several months back. I will check my work. I was told that QSPI loading support for STM32F769 would be supported directly in J-Link software, do I need to ask Support for the official STM32F769 QSPI Flash loader? The "official" flash loader is shipped with the latest V6.20 version but it is currently only been tested for a STM32F746NG eval board. So for the STM32F769 some adjustment will be necessary. I not...

Thursday, September 14th 2017, 4:08pm

Author: SEGGER - Nino

SystemView Crashing on Windows 7

Hello Leepeng, Sorry for the delay in response. What target device are you using? Is it a eval board or custom hardware? Could you provide us with an example project where this issue is reproducible so we can narrow down the issue? Best regards, Nino