Saturday, February 17th 2018, 8:26pm UTC+1

You are not logged in.

  • Login
  • Register


Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Message information
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Yesterday, 2:33pm

by ubermensch

Hi Nino,

Here are the logs as you requested. Hope that this helps. I hope that my suspicion about J-Link is wrong, since in my 3-case experiment the bug appears whenever J-link is present and being used.
ubermensch has attached the following image:
  • stack.png
ubermensch has attached the following files:
  • log1.txt (221.4 kB - 1 time downloaded - Last download: Today, 1:32pm)
  • log2.txt (245.97 kB - 1 time downloaded - Last download: Today, 1:32pm)
  • log3.txt (227.9 kB - 1 time downloaded - Last download: Today, 1:32pm)

Thursday, February 15th 2018, 9:29am

by SEGGER - Nino


*Thread has been moved to J-Link/Flasher related*

Thank you for your inquiry.
Such an issue is not known to us.
Generally J-Link will only execute tasks that the IDE tells him to do. So whatever the IDEs tell J-Link to do when you insert the semaphore will cause the hard fault.
Could you provide a J-Link log file of the session when the error appears?
Please understand that we can only give advice for SEGGER products. Eclipse, FreeRTOS and CCS are all not SEGGER products, so please get in touch with the proper support channels as this is most likely no J-Link issue.

Best regards,

Sunday, February 11th 2018, 7:44am

by ubermensch

Having Hard Fault in Tiva Launchpad FreeRTOS with J-Link but works fine in ICDI

I'm doing a relatively intermediate FreeRTOS learning exercise with Tiva TM4C123GXL Launchpad from this site especially that Task_SPI_Transfer project.…he-tm4c/?page=2

The problem is that whenever I'm using SEGGER J-Link EDU, I always end up with an undebuggable hard fault once I run it. I followed the setup and wiring for the launchpad to J-link from this website below

except for the 3.3V and GND which were pointed wrongly in the picture.

I have tried three test scenarios for that:

IDE - Eclipse Oxygen with GNU ARM Eclipse plugins; Debugger - J-Link
Result: Hard fault. The CFSR register points me to bus fault, precise error, but the instruction address is 0x40000 which contains absolutely no code. Other things that I've noticed is that a certain thread disappeared (thread #5) and this message appeared. I am attaching that picture.

IDE - TI CCS v6.2; Debugger - J-Link
Result: Hard fault. The CFSR register points me to imprecise error. Tried to reduce clock from 80MHz to 40MHz then to 20MHz. Nothing changed it's still imprecise hard fault.

IDE - TI CCS v6.2; Debugger - the default ICDI
Result: It WORKS! It should be since many people said it does (based on the forum). Strange....

What's wrong with J-Link here? I also want to note that in the first exercise in the webpage, about a LED blinking task, I was able to run it in all THREE CASES above with no problems. But once I insert a semaphore, like xSemaphoreTake() just like in the project I'm having trouble with, that's when the hard faults start to appear.

I can't settle with just TI ICDI; the reason I bought J-Link is because it's more universal, it has thread-awareness, and I can do a FreeRTOS tracing via SystemView. I can't do those things with ICDI. That's why I need help to fix this.

EDIT: Oops seems like I placed this in the wrong thread. Please transfer to J-Link forums if needed.
ubermensch has attached the following images:
  • hard_fault.png
  • before.png
  • after.png