Wednesday, December 13th 2017, 8:07am UTC+1

You are not logged in.

  • Login
  • Register

Reply

Dear visitor, welcome to SEGGER Forum. If this is your first visit here, please read the Help. It explains how this page works. You must be registered before you can use all the page's features. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Message information
Message
Settings
Automatically converts internet addresses into links by adding [url] and [/url] around them.
Smiley code in your message such as :) is automatically displayed as image.
You can use BBCode to format your message, if this option is enabled.
Security measure

Please enter the letters that are shown in the picture below (without spaces, and upper or lower case can be used).

The last 3 posts

Thursday, December 7th 2017, 1:34pm

by Mosbat

thank u for reply. I 've used GUI_CreateDialogBox().is it possible that AHB BUS priority cause this problem?

Monday, December 4th 2017, 3:50pm

by SEGGER - Schoenen

Hi,

How do you create the subpage?

If it is a dialog, do not use GUI_ExecDialogBox() or GUI_ExecCreatedDialog(), since these functions are blocking and won't return until the dialog gets deleted. GUI_CreateDialogBox() should be used instead, which allows the application to continue.

Regards
Sven

Sunday, December 3rd 2017, 9:29am

by Mosbat

Peripherals Stop Working during changing page on emwin.

Hi there.
I 've used keil 4.7 with emwin 5.16 on lpc1788.my gui consist of a main page and some sub pages.when gui shows main page every thing works perfect.but when i i hide main page and show a subpage , peripherals (usb,usart,caputre intterupt) stop working until i return to main page again.how can i solve this problem.
another problem is when i compile program without debug information , my lpc1788 hangs.